Databases being confused with each other on sync

I have a problem with my databases that rears it’s head when I’m dealing with sync stuff either via Mobile or the integrated Dropbox sync.

It seems my databases get confused with each other. I don’t really know how to explain this but the following specific example is my most recent issue:

  • on DTPO on the Mac I have databases A & B open
  • In Preferences > Sync I see them both
  • I close Database A and Database B disappears from the Preferences Sync box.
  • To get it back I have to close all databases and reopen them one by one. But then I run into this issue again. It just can’t tell which databases are open and when I close one it removes a different one from the Sync box.

I’ve had similar issues when trying to Sync using DTTG on iPad. So, I’m thinking somehow my databases are the issue. I have tried repairing them, optimizing them AND rebuilding them using the built in options, but it still happens.

Any ideas?

Right now I just can’t sync.

Have you copied databases in the Finder?

Yes, I have and I have suspected that caused a problem. I think what I did (years ago) was to split a large database by duplicating it then deleting different parts in each copy and renaming them. Was that a “no no”? :wink: If so, how do you advise I fix this mess?

Yes, that is a very bad idea. Please start a Support Ticket. Thanks.

OK, I just opened a ticket.

In the meantime I found this thread:

and advice in it to resolve the issue: basically make a new database then select all and drag and copy files en masse into new database. Is this still a good way to resolve this?

Yes, but I suggest cleaning up your Sync Location too.

OK. My Sync location is Dropbox, how do I “clean it up?” Just delete all the files in Apps > Devonthink?

Please respond by clicking the link in the Support email so we can keep the history of the issue in one place. Thanks. :smiley: