Default app to open PDF shows as Preview different to Finder

I have set my Mac to open up all .pdf files with a different app (PDF Expert) instead of the default app (Preview). This works so that when I double-click any PDF, it will open with PDF Expert and not with Preview. I had restarted my Mac after that change. The change goes for any and all PDF files.

In DEVONthink v.2.10 as of June 18, 2018, when I want to open the PDF file, not within DEVONthink but with my default Mac app by pressing Shift-Cmd-O, the file correctly opens with PDF Expert.

However, when I right-click on the file in DEVONthink and choose Open with… then I’m prompted with a long list of options but at the top it shows Preview together with the added info i[/i]. When I select that, then the PDF file opens in Preview.

This seems like a bug to me in the sense that DEVONthink apparently has not updated its list of options from my system and still shows Preview as default instead of showing PDF Expert as the default.

When I right-click on a PDF file on macOS desktop for example, and then choose “Open with…” I correctly see PDF Expert as default being listed at the top of the list of options.

It’s just a cosmetic thing but I thought I’d report this.

This list isn’t cached and always retrieved from the system. Does a reboot fix this?

Unfortunately, a reboot does not fix it. It’s not a big deal but looks like a bug to me.

Could you please post screenshots of DEVONthink’s Open With menu and of the Finder’s Open With menu after selecting the same PDF in both of them? A screenshot of the Finder’s Info panel of this item might be useful too. Thanks!

Attached are the screenshots.
Screenshot 2018-06-21 02.55.30.png


Screenshot 2018-06-21 02.54.03.png

And here’s the info window from Finder.

Thanks for the screenshots! Does applying the “Change All” option (see Finder’s Info window) make a difference? In addition, does it make a difference how you create a PDF? Please check whether a PDF created by DEVONthink (e.g. via Clip to DEVONthink) works as expected. Thank you!

I clipped a web page to DEVONthink as a PDF. The subsequent behavior is the same as described in my posts above.

Also, I had already set to open all PDFs with the app PDF Expert as default using the button “Change All…”

Can you reproduce the situation on your end? I’m on El Capitan. I use DEVONthink Pro Office version 2.10.

I have the same setup here, using PDF Expert, and it works for me as expected. As a suggestion, perhaps try changing the default PDF app to something else (using Change All). Test if that works, then change it back to PDF Expert and see what happens.

Thank you, this did the trick. I quit DEVONthink, then changed the default app to Preview, then back to PDF Expert. I then restarted DEVONthink and it now correctly shows PDF Expert as the default app.

Issue resolved.

1 Like

Yea!

tried the above from mypointofview but no luck - is happening in v3!

It is the system that determines with which program a certain file is opened. This has already been described above. Launch services are responsible for this. Sometimes these services are damaged, then they can be repaired with a terminal command:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain u -domain s -domain l -v

But please be careful: You can cause a lot of chaos with the terminal. Therefore, please only use it with a previous backup and on your own responsibility.

If you have utility programs such as CleanMyMac X, or Onyx, or others, they contain a feature to rebuild the Launch Services database, which is much easier than using Terminal.