Default document size not working in preview window

I am using 3-pane view, sidebar on the left, document list on the top, preview window on the bottom.

In preferences->multimedia, I have Image Display: set to ‘Zoom to Width.’

This is not working for pdfs. Is there something else I need to address, or is it perhaps a bug?

Of note, if I use the shortcut ctrl-cmd-W, it works, but I just prefer not to do that for every document.

Thank you!

This is only a setting for images. There’s a separate PDF display setting plus an option to automatically adapt the size.

Thank you, sir. Its just not obvious what that does, and there are no options for width as there are when you have a pdf open and use View->Zoom. But it does make my pdfs full-width, which is what I wanted to achieve.