Default zoom for Markdown documents


Is it possible to set a default zoom/font for Markdown documents?

I see I can set the font size for plain text and that works fine, but I seem to have to use the View/Zoom In option for Markdown and the setting isn’t sticky across docs, or even for a specific doc (if I zoom a Markdown doc, then navigate away from it, then back, the zoom resets).

I use Markdown a lot and this is a bit of a bottleneck.



This is not yet possible but thanks for the suggestion.

Are you looking to change the default zoom in the Markdown display (Best Alternative) view or in the Markdown edit (Text Alternative) view?

The Markdown document display (Best Alternative) view font size is set by the font size set in Preferences>Editing>Rich Text and Note Font. Any changes made to zoom in/out for the document will not be sticky across documents, as you mention. However, the font size set in Preferences is sticky.

The Markdown document edit (Text Alternative) size is configurable as well, but it is a lesser-know process to change. This is done by by using Shift-Control-Command-equal key to increase the display size, and also Control-Command-minus key to reduce the display size. This is a global command that will change the display for all Markdown* documents. The actual size of the font in the document will remain unchanged. Note that (in a good way) this is not the same as temporarily changing the font size with Command-equal (larger font) and Command-minus (smaller font) zoom in/out command.

  • Also note that this command works with all text documents (Markdown, RTF(D), and plain text), and can be different for each document type. As such, you can set the plain text documents to be larger than Rich Text documents, and set Rich Text documents to be smaller than Markdown documents, and all documents of that type will display in that size. This can be very useful, for example, if you want documents to be formatted with a larger font for syncing/display in DEVONthink to Go, but displayed smaller on-screen in DEVONthink macOS.

Many thanks - it was this bit, but I think I’ve uncovered a little bug which is why I wasn’t seeing the changes (I’d tried this earlier and it didn’t seem to be working).

To replicate, open Preferences>Editing, then change the font for Rich Text and Note Font, as you mentioned. This works for the first time you select a new font/size, but subsequent changes don’t have any effect unless you close the font selector and open it again. For example, change it 18, switch to a new doc, then switch back to the original and the font has changed. Without closing the font selector, select another font, switch docs and back again and there’s no change.

I think it’s the switching docs and back again that causes the issue, but you have to do that to see the font change in the document. Not a biggy once you know what’s going on.