Delete highlight not visible on iOS, Apple Pencil intermittently not available for use on iPadOS for PDF highlights

Still working out my workflow, but trying to use devonthink to highlight PDF since PDF Expert does not integrate nicely.

In iOS, when I make highlights of pdf files there is no way to delete (other than back button). Whether in edit mode or view mode clicking on the highlight does not bring up the menu with option to delete highlight. Searching the forums I see this was a previously reported error back in 2019 thread, but seems it should have been fixed. Is this persistent issue, user error, or do I need to place a ticket?

With regards to iPadOS, when I enter the PDF edit mode, I do not have the Apple Pencil at that top of the screen (aka which allows finger to scroll and Apple Pencil for annotation/highlight). Interestingly if I close and re-open to edit mode typically between 3-5 times at some point the Apple Pencil will appear. It does not matter if my pencil is in “charge mode” connected to my iPad or already in my hand ready to go. Again, known issue, user error, or does this need a ticket?


When you tap the highlight, you should see a popup menu. Tap the Trash icon.

I agree this is supposed to be the action. When I select files on iOS no popup appears at all on the highlight. This can be reproduced across multiple pdf. The action with the popup works find on iPadOS.

  • What version of DEVONthink To Go and iOS are you running?

  • Does the issue persist after quitting and relaunching DEVONthink To Go?

iOS 15.6
Devonthink 3.5.4

Persists after restarting and after complete reinstalling the app on ios

Can you post a screen capture of a PDF you just applied a highlight to, then tapped the highlight?

One with edit open and one with it closed. On both I have tried to tap and select the highlight and nothing shows up.

Is anyone else able to reproduce this?

Of note the iPad works fine, but my work iPhone on same version of iOS acts the same way. It’s as if it won’t even allow me to select the highlight.

I’m not able to reproduce the issue here so far.

Is there a way to submit a ticket. Or any other ideas of what to try? It makes pdf editing/highlighting unusable in the app.

I’m using highlights as a work around for now.

Also any idea on the iPad why the Apple Pencil only intermittently shows up even though connected?

On DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket.

Also any idea on the iPad why the Apple Pencil only intermittently shows up even though connected?

Not at the moment as I’m not seeing the behavior here.

I was able to open iPad app, make annotation, delete iOS app and then reinstall and function worked correctly. Interestingly when I then adjusted pdf settings for scrolling to continuous the problem reappeared and the text is no longer selectable with the popup.

Thanks, I submitted a ticket.

Thought I figured it out but apparently not. Issue is back and again renders annotating unusable in app. I included a screen shot of a “free text” from iPad, it selects the item but note that there is no menu above the selection to delete, etc.

I tried this for fun, but I can’t recreate the issue, the menu pops up for me. Sorry!

No problem. Thanks for trying. I am not actually sure now if what I did when the menu came back in fact happened. I’m getting the menu maybe 5% of the time but can’t figure out what is causing it.

For now I’m using the open in function. PDF viewer is good enough and at least has bookmarks (which is strange since DTTG seems to use same viewer, and it even shows the “bookmark flag” from pdf viewer in DTTG but no option to add to them). Highlights wasn’t for me, and my wish list item like everyone else seems to be pdf expert but has known issues.

We will look into in this week but I’ve had no epiphanies so far.

1 Like