Delete prompt for individual indexed file in group

my delete prompt for only in database does not show up. I sent my indexed file to the trash and then when im trying to delete it from my trash it only lets me delete it completely. I looked at the help section on devonthink and it shows two prompts. how do I default the prompt that allows me to delete only from database?

I want the option to delete only in database.

This alert is only available after trashing indexed items not located in indexed groups due to the tighter & bi-directional file system integration of version 3. It’s not possible to index a folder only partially. If that’s desired then it’s recommended to index the necessary contents of the folder instead of the complete folder.

@cgrunenberg ah, I see. the only reason why I want to trash it is because devonthink doesnt let me exclude this file from tagging. It’s a .css file and it has about 41 # tags and its making my tagging system a mess. maybe you can help me with that instead really quickly

Is the option to convert hashtags to tags in Preferences > Import enabled?

@cgrunenberg yes, but I want to keep it on for my future imports. should I turn it off quickly and then index it again just for this file?

I thought exclude from tagging meant that it won’t show up in my tag searches

One workaround is to disable the preference and to add the hashtags via a smart rule to the desired files. However, the next release will also improve this and ignore the contents of files which usually don’t contain hashtags.

okay, ill see what I can do. @cgrunenberg

yea, that fix is much needed, I like to index my obsidian vaults in devonthink and having files that are .css making tags like there is no tomorrow is troublesome. it makes just 5 files reach over 300 in tags for purely colors.

.css files are constantly updated and/or replaced so I think you can imagine the extra work for no reason on tags

thanks for your replies and hopefully the next release is soon

Chris, please consider making DT ignore hashtags inside codeblocks in MD files. There might be others that keep css snippets in md files, which ends up causing the same problem :wink:


Thanks for the reminder :slight_smile:

1 Like

I see that there was an update for the .css files to not convert to hashtags. I still get this issue when indexing the files and they are .css files. is there a setting I need to turn on? I can’t seem to find it. Thanks

also, hashtags are being created 2 times and chopping part of them when indexing .md files that contain tags. hopefully this can be fixed


on latest version

I am not seeing any issue here…

  • You’re running 3.6.1?
    • On what OS?
  • Have you rebooted the machine?

this is seen in the tags section when its unified. you can see all of the tags created. for example:

  1. Work_is
  2. Work_is_not
  3. Work_is_not_life

is what happens when I start to index .md files and then some styles from my .css sneak in as well. I had to manually delete them


  • You’re running 3.6.1?
    • On what OS?
  • Have you rebooted the machine?

ah, right.

  1. im running 3.6.1
  2. Mac OS big sur
  3. a thousand times

A screenshot (including the source of the document) would be useful.