Deleted custom metadata field keeps resurrecting itself (despite deleting all entries)

I’m seeing an issue with a deleted RTF custom metadata field that keeps reappearing.
What I’ve already tried is batch processing all documents, groups and tags in the database to remove any data that used to be in that custom metadata field.
After deleting the field in the settings, my assumption would have been that it’s deleted for good but apparently it isn’t.
Any help would be appreciated - there are some related threads but none really answered this.

You might want to check if the data is deleted from all devices you sync with, too.

Had the same problem (but not with custom meta data of type RTF). The only thing that helped to get completely rid of the meta data was to delete it from every record. However, I used a scripting addition that doesn’t work on current macOS versions anymore.

So I think your only option is to try whether Script: Remove some custom meta data also works with custom meta data of type Rich Text. I did not test the following limitation with this new script:

Due to an AppleScript limitation it’s not possible to remove meta data of type rich text.

Reading the script and its description again now I don’t see a reason why it should not work.

I ran your script on all items in my database after adding the identifier for the field needing to be deleted. This seems to have worked, as far as I can tell. Thank you!

It seems to be necessary to first delete the field in settings and then afterwards run the script. In the reverse order, which I tried in my first attempt, the field did come back.

1 Like

Another observation in case it helps someone with the same issue:

I’m not 100% certain of this yet, but apparently what can also work is changing the field type to Boolean, then setting it to 0 via batch processing and finally deleting the field in the settings.

Interesting. We’ll try this if we can reproduce the issue.
Thanks for sharing your observation. :slight_smile: