Deleted data isn't deleted and Pro Package isn't working

DTTG was taking 2,99 Gb data storage for a couple of databases.
So I bought the in-app Pro Package, set the Purge settings to “Keep 250 items” instead of “Keep all”.

  • Nothing happened to the storage amount
  • Re-synced, but nothing changed in storage amount.
  • Opened all of the databases one by one, and re-synced them solo, but nothing changed in storage amount.
  • Figured the purge setting perhaps would only be applied on new databases and not the existing ones (which would be odd though), so deleted all databases. Storage amount changed from 2,99 Gb to 2,83 Gb
  • Figured it might be caching or temp files, so rebooted my iPhone, after reboot, DTTG was still taking 2,83 Gb (without any databases within it)
  • Deleted DTTG and all of the storage had been released
  • Reinstalled DTTG and the data storage is equal to the size of the app
  • Set the purge setting to 250 files before adding any databases
  • Added the same databases as before, storage amount is 1 Gb without opening any database or file yet (as I think I understood the purge thing, it would only download the index, files would only be downloaded upon tapping on it and only the last 250 files (in my particular setting) would be kept in storage… so I expected to have no storage changes since I haven’t tapped any file in any database yet)


  • iPhone6 64gb, iOS 10.0 (developer beta 8 )
  • DevonThink To Go 2.0.3 (15979)

By the way, about the 2.0.3 (which is off topic and actually deserves it’s own thread):
Up to 2.0.1 (I’ve missed the 2.0.2 update) everything worked flawless and I haven’t experienced any problems.
After updating to 2.0.3 (which says to fix problems), my pleased usage disappeared completely… :frowning:
Got a lot of crashes after the update (some issues related to another thread about the “Migrating Database message” ), and everything seems to work very, very, very, very slow… Lots of times, after tapping an item, the app seems to be frozen for about a 30 to 60 seconds before processing the tap and reacting again…
So the latest update was, for me personally, only a huge regression instead of a progression… :frowning: :frowning: )

Please start a Support Ticket.

Same for me - 2.0.2 was working just fine and then 2.0.3 came along and destroyed what was working nicely on an iPadMini4 and an iPad3. Now I cannot get anything going on the iPad3 after having reset the whole thing and needing to set up my iPad again and the iPad Mini 4 is only partially functional.
Support team has stopped responding to my emails now!

Maybe because it was the weekend? Now, Monday morning, we have worked through all open tickets.