DEVONagent doesn' t work


anybody else having this problem: DEVONagent simply just don’t work? Adding some word into the search window, then pressing start button -> it searches for a second, than returns nothing. The first beta that I had was fine. I have 10.2.8, but this would be the only think not working (and I’m a real poweruser).

anybody with an idea?

Thank You

  1. Do you use a proxy?
  2. Delete the preferences "com.devon-technologies.agent.plist" and then try the same procedure again.
  3. Which plugins are activated? Anything in the log? Or is this empty too?

Is it possible that you somehow have "zero" threads entered in the downloads preference for DA?

Even if one enters "0", DA automatically corrects this. Has to be something else…

I am running OS 10.2.8, and DA is working fine so far. The new DEVONtech forum plugin provides a quick, searchable knowledge base too. An obvious thing, but check you are not making a general internet search with just the DEVONtech Forum plugin checked in the query window settings.


I have the same problem. Also running 10.2.8. E.g. I want to search for "Belkin" - need info about the new BlueTooth mouse…

>1. Do you use a proxy?
Yes. WebBrowsers and Emailers work. DevonAgent doesn’t.

>2. Delete the preferences “com.devon-technologies.agent.plist” and then try the same procedure again.
Doesn’t help.

>3. Which plugins are activated?
German Internet, Internet, MetaCrawler

>Anything in the log? Or is this empty too?

OK, I added all Mac related plugIns. Now it got 1 entry in the log: … mp;range=0

with the error "not found".

I would expect hundreds of hits…

There’s a known issue related to proxies requiring authorization. This will be probably fixed in version 1.1.1.

Our proxy doesn’t require authorization…
It just uses some high port numbers for http / ftp / https …

I tried it at home - without proxy. Hey, it works. Scanned 5GB and really found some useful info. Interesting…
But at home I have to pay the traffic - at work I’ve got a T1 line for free - with proxy.
After that bug got fixed, I will start evaluating again.

The next release (v.1.1.1 or v1.2) should improve the proxy support. If you’re interested in testing this version, just let me know!

Well, it seems that the proxy bug is still alive and well with v1.2. I fired it up, tried running a search and it’s still hanging on “Initializing…”, just as it did with v1.1. The same results occur after trashing results, etc., this is on OS X 10.2.8, and I don’t believe our proxy requires authentication (Though I could be wrong about that…)

Any idea when/if this will be fixed?

Also, is there any way to download v1.0?  I seem to have deleted my copy of the dmg, and that is the only version that functions here at work…

Will be fixed in v1.2.1 (coming after the holiday season). Actually downloading web pages hasn’t been modified since v1.0 so this should (!) be identical in v1.0. But I could send you v1.2 via mail.

Well I still have the 1.1 and 1.2 dmgs, but neither of them plays nice with our proxy.  But if you could email me v1.0 (or whatever the last version to work behind a proxy was), I would appreciate it.

Unless 1.2.1 is coming fairly soon after the new year, in which case I’ll just wait for that (I’ll be away from work over the holidays…)

I’ve just sent you the 1.0 archive.