Devonagent returns NO results

The past few times when I tried to use Devonagent I would enter a search term (e.g. insect biomass) and I get NO results. Other search terms are similarly non-responsive. I uninstalled Devonagent and downloaded the latest version and got the same result: i.e. NOTHING.
I have a plain jane Mac-Mini 2018, Big Sur that works fine with Devonthing and Devonsphere but Devonagent is just non-responsive. I put in the search terms, and nothing happens.

What to do?

Please post a screen capture of the search window with no results.

Thanks for the fast response. Attached is the screen shot. I should have noted that at the top of the screen it says “All cached pages:pollution” The message changes, but it always relates to 'all cached pages:" which might mean it is looking at a cache somewhere, but not the web. I have tried to get rid of that, but with no luck.


Did you try choosing a different plugin under the search options, i.e., the magnifying glass?

I don’t even know where to start with that. There is NO magnifying glass, apart from the one at the extreme left of the search menu/window, whatever. I did try other topics from there, but no luck.
It is essentially a dead program. The only thing is the statement All Cached Pages: pesticide biodiversity (which is the search term). I tried emptying the cache, but nothing obvious happened.


Could you please post a screenshot of the same window as in the first screenshot, but with the search options open (they open when you click on the magnifying glass in the left of the search bar; it is the magnifying glass depicted in the screenshot you posted)?

And clicking on this magnifying glass (or pressing the down arrow key) opens a popup to select the desired plug-in or search set. Currently you’re using the All Cached Pages (see title of window) plug-in which scans pages cached by former searches and therefore doesn’t find anything.

1 Like

That is the answer. I switched the search plugin to Google, and got stuff. I don’t know how “All Cached Pages” got where it was but now things work.
Many thanks