Devonagent: unable to launch URL from (Safari) bookmarks bar


In DA 2.3.1 (the “browser” feature), when using the bookmarks sidebar (Command+B), I am no longer able to launch any URL by clicking on it. I just get an error sound, no error message and nothing else.
While keying directly the URL in the address bar works fine.

Edit: the options (“open in new tab”, …) listed by clicking on the wheel at the bottom of this bookmarks sidebar are not available either.

The bookmarks have not been imported through an “import” feature but have been set up through the DA Preferences > Bookmarks > Safari.
I am using Safari Béta 4 as default browser.

This had been working very well for a while. Could it be related with the Béta of DT Pro?

Your 2 cents or more are welcome. Thanks :slight_smile:

Up !
I suspect that the whole DT team is on vacation or week-end.
Hopefully they should come back some day and I am sure they will provide me with some advices to fix that very uncomfortable glitch :slight_smile:.

Up! Nobody able to help?

I confirm that DA browser does not work with the Bookmarks sidebar any longer while it worked perfect earlier.

I can’t replicate your problem. The bookmarklets set up in Safari work properly from the bookmarks sidebar of DEVONagent.

I’m still running Safari 3.2.3.

Thank you Bill for the answer.
Safari 4 is no longer a Béta starting from yesterday and I am unable to reinstall a Safari 3 version to compare DA behaviour with both versions.
I just installed the official Safari 4 version and, unfortunately, the problem is still here.
What could I do to recover all DA features?

I’ve now installed Safari 4 and still have no problem – all links and the bookmarklets in the slideouts are functional.

Thank you very much Bill for this precious test.
It seems that the problem does not come from Safari. But where does it come from?
Should I reinstall DA or are there more investigations to perform?

The usual suspects.

Replace the .plist file in /Home//Libray/Preferences/. Possibly reinstall the application.

OS X maintenance including cache cleaning.

If you have installed a hack utility recently, try removing it and logout/login.

I have the same problem, since Safari 4. I’ve removed the preference file, removed all my input managers, but still I get nothing in the Go menu, and nothing but beeps from the sidebar. Safari 4’s bookmark file format has changed, don’t you think that DA might have been affected by this in some way?

Safari 4 uses a revised bookmarks format and therefore DEVONagent 2.3.1 can’t use them anymore. The next maintenance release will fix this of course.

Thank you for the clarification, Christian.
Looking forward to the coming fix.

Interesting. Although I’m running Safari 4, DEVOnagent 2.3.1 can still successfully link to URLs in the slideout holding the Safari bookmarks

But I imported those bookmarks from Safari 3.x. They are still working in DEVONagent.


I am re opening this post just to know whether the team is working on the fix and when it could be shipped.

Not so dramatic but very uncomfortable for DA users who have their bookmarks in the Safari 4 version.

Hope you will not forget us. Thank you!

Christian noted that there will be a DA update.

After update of Safari to version 4.0, I continued to have use of the Safari bookmarks in DEVONagent, until I added a bookmark in Safari. At that point, the bookmark and links slideouts in DA no longer worked.

Then I added still another bookmark in Safari 4 – and the slideouts and Go menu in DA are again fully functional. Give that a try. :slight_smile:

Thank you for the trick, Bill. I made what you recommended. Unfortunately, no way on my side. The new bookmark created in Safari and the former ones have a similar behaviour: they keep being inactive in DA.

I am a fan of DA and do hope that Christian will provide us with a prompt fix.

Thank you :slight_smile:

Just send an email to cgrunenberg - at -

Does this problem have a solution/work-around yet? I’m in a similar situation

See above. An intermediate build is only available on request.

I can confirm that the intermediate build delivered by Christian fixes the problem :slight_smile:.

Hello Christian,

The intermediate build of DA (2.5) you delivered to me (and to some of us) expired on 30th of September and is no longer valid. As far as I remember all Devon Beta versions are limited to a 4 or 8 weeks long life. I tried to reinstall DA 2.5 from the dmg file but this does not fix the problem and DA keeps being in the “expired” state.

I would be grateful if you could provide again with a temporary workaround… waiting for the final and official release.

Thank you!