DEVONthink 3 crashes on opening Github bookmarks

I am not able to open any Github bookmarks. I have bookmarks imported from browser and other bookmarks are working. But none of the bookmarks to are working as the app crashes on click. If I right click and choose Open it opens in new window and the app doesn’t crash.

github bookmarks don’t cause any issue over here, this might either be an issue of the WebKit framework and/or depend on the bookmarks. Which version of DEVONthink and macOS do you use? A screenshot of Preferences > Web would be also useful.

I am using DEVONthink 3.9.1 and macOS Ventura 13.6.

Github link that I tried is crashing: GitHub - kmorkos/flutter_photokit: Flutter plugin to interact with iOS PhotoKit

No problem to view this link using the same macOS version over here. Does updating to 3.9.4, rebooting the computer and/or emptying the cache fix this?

I too have this problem. I submitted a bug report back in April about it. Jim’s response then was:

This is actually a crash caused by the Touch Bar, not from DEVONthink. This is something Apple would need to address. You could try setting the TouchBar to show the expanded Control Strip in System Settings. However, I don’t have a Touch Bar Mac running Ventura so I can’t give specific directions on that. If you do make that change and it alleviates the crash, please let us know.

I tried adjusting the TouchBar setting but the behavior persists. Updates to the OS and the DT have not fixed the problem. Clearing the cache & rebooting have not fixed the problem. Turning off Javascript has not fixed the problem.

I currently am running macOS 13.5.2 and DEVONthink 3.9.4.

If anyone has a solution, I would greatly appreciate it. To prevent accidentally opening a Github link and crashing DT, I’ve resorted to converting all Github bookmarks to Markdown for the time being. Not a pretty solution.

TouchBar Mac?

PS: Crashes should be reported in our support ticket system, not here. Hold the Option key and choose Help > Report bug to start a support ticket.

Okay. Not TouchBar mac. Running on iMac (Intel).