Devonthink does not sync whole database

Hi there,
I am just setting up my new iMac, and wanted to sync to my databases on the iCloud (used a Macbook and iPhone with iCloud sync so far). The problem is, that not the whole database is synced, but only parts of it. Tried it twice now, and every time the same: From the 1.3GB database there will be transferred only about 150MB. Those documents are ok, but a lot is missing. Strange enough, when I create a new document on my iPhone, I can sync it to the iMac as well as to my Macbook, so the sync seems to work. What could be the reason for such a behavior? Am I missing something?

On the Mac, go into System Preferences > Apple ID > iCloud Storage and click the Manage button and check how much space is being used by DEVONthink To Go.

There it says 2.9GB, but this is the sum of several databases. On the Macbook they take about 2.5GB together. I will take a look now, what it looks like on the iMac. Or would it be a better idea to first copy the databases, and link them to the sync store after that? I imported them now…
On the iMac, they have about 1.3GB together.

You could copy the databases to the other machine and enable syncing for sure.

One further observation: When I create a document on my iPhone, it syncs to the iMac, from the Macbook it doesn’t… But from the Macbook it syncs to the iPhone. I am confused! :exploding_head:

From the iMac it syncs to the MB and to the iPhone… Is there anywhere a preference, that some files are excluded from syncing from a Macbook to an iMac?

No there is no preference or way to exclude syncing files or groups. It’s all or nothing.

Also, the behavior of one device is no sign that other devices will behave similarly, any more that have two cars of the same year/make/and model would run the same.

It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually, starting with the simplest…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync , disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.
  • In iOS’ Settings > your Apple ID, sign out of iCloud and sign back in.
  • In macOS’ System Preferences > Apple ID > Overview, sign out and back in.

Ok… I will try a bit around and let you know, what worked for me (if anything works, but I think, there will be a way :grinning:)
Thanks a lot for your help so far!

Yes, please let us know what works in your case.

And you’re welcome :slight_smile: