DEVONthink Doesn't Snap with BetterSnapTool

I use BetterSnapTool frequently to arrange windows on my iMac. More often than not, DT3 doesn’t cooperate. If I attempt to drag an open DT3 window to the screen’s edge, this action should cause the window to expand to exactly half screen width and full screen height–but nothing happens. It seems that DT3 is the only app that has this intermittent problem.

Works OK here.

So, I tried closing and re-opening DT3, but that didn’t change anything. It wasn’t until I closed the 25 databases I had open while DT3 remained open, then re-opened all 25 databases, that snapping worked again.

That’s strange as that should have no bearing on window behavior.
Can you reproduce this behavior consistently?

This happens intermittently. I haven’t been able to put my finger on what triggers the disconnect. It happened again just now with just three databases open. The one DB that I was viewing files in has four external indexed folders and many internal folders with 50+ tags and the folders are taggable (if that has any relevance). When I selected a different database, the snap worked again.