Devonthink forgets the Check Spelling As You Type setting

Devonthink forgets if you set the “Check Spelling As You Type” to True (in the Edit/Spelling menu). At first I assumed it was remembering it on a per-document basis – you might want to check the spelling for an essay you are working on, but not for a web page you’ve collected or a code listing – but it’s not doing that. It’s just forgetting it database-wide when you finish editing a document where you have set it to True.

It is not the behaviour exhibited by TextEdit, Apple Mail, etc. Is this deliberate?

Bump. No one got any ideas?

In DEVONthink Preferences > Editing, check the box for “Check spelling as you type.”

Also, select in the menu bar Edit > Spelling > Check Spelling As You Type.

Of course, DEVONthink will let you spell check text that, perhaps, someone else wrote. Just select the text and choose another option from the menu bar selection above. (Remember to go back and select Check Spelling As You Type, later.