Devonthink Pro and DTTG sync problems

I have been trying to use DT Pro for several months with latest release of DT and DTTG. I have tried syncing, re-syncing, rebuilding databases for weeks. Tried turning on CloudKit and Bonjour on all devices. Mostly use this database to index pdf files in the finder.

What can I do to make all devices sync the same? I am spending more time trying to sync than getting any work done. Any help will be appreciated.

My computers:
A iPad Pro M1 DTTG
B iPad Pro DTTG
C Macbook Pro DT Pro
D iMac DT Pro

Re-synced A
Re-synced B
Re-built databases on C and D

Info on A shows 1286 items
Info on B shows 1313 items
C shows 782 items
D shows 680 items

These are the latest item counts in various groups on various devices A,B,C,D
? Means group not shown on device

Groups A B C D
Col 21 21 21 18
ColSB 10 10 10 10
iB 12 12 12 ?
It 5 5 5 5
Ih 17 17 17 15
Md 4 4 4 4
Nt 5 5 4 5
Sbi 140 139 8 41
S-sb 25 25 24 24
Sf 4 4 4 3
VRIB 20 21 ? 17
VRIS 29 29 29 27
VRTB 22 22 4 6
VRTS 23 23 22 23
VSB 28 27 27 27
WF 24 24 25 24

  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.

Thanks for getting back to me.
Here are the answers to your questions for the database in my previous post.

My computers:
A iPad Pro M1 DTTG - no triangle - says no sync in progress
B iPad Pro DTTG - triangle - says iCloud(CloudKit) 14 items left to be updated
C Macbook Pro DT Pro - log shows 8 times 1 item left to be uploaded then Failed
D iMac DT Pro - says successfully verified

The number of files in the various groups still do not agree.
Is there more of a problem syncing indexed groups? I have 2 databases that are not indexing the group files and the file counts are pretty much the same in each device.

Is there more of a problem syncing indexed groups?

Indexing must be used with forethought and care.
Where are you indexing files from on the Mac?

I have monthly pdf documents in various folders on iCloud that I am trying to sync to. I have 2 macs with DT and 2 iPads with DTTG mainly for convenience around the house. The Macs seem to handle the syncing pretty well as the groups appear to have the same number of documents on each Mac. DTTG groups do not sync of the documents in them and the number of files in the groups are different between the 2 iPad pros and the Macs.

I have noticed that DTTG appears to sync ok on other databases I have with no indexed groups - where I dragged documents into DT. This has led me to believe that DTTG 3 is not so good yet at syncing indexed groups.

Maybe I would be better to consider dragging my documents into DT, not index them, and not put them in iCloud? This would probably be better for security reasons. I originally had the documents in iCloud and was hoping to use DT to help sort and analyze them.

Thanks for your help.

You’re welcome.
On the B IPad, try emptying the Trash.
Also tap the ? > Contact Us to start a support ticket for that IPad.