Devonthink pro freezing


i’m a brand new member on this board and i’ve discovered devonthink one month ago.
I’m currently testing this software on my macbook pro penryn 2.4 ghz. Everything was great until i tried to import multiple pdf : that was really slow and sometime freezed.
Now i have a database of almost 2Go. When i do a research, pointing on a particular pdf, and try to click on it, i get the awful multicolor ring and i’m unable to do anything.
What should i do? Am i the only one with this trouble?

Thanx for any help, i really want to use this program.

First off, that’s unusual. DTP is generally a remarkably stable program.

That being said, there seem to be some problems with PDF imports in the public beta. DT 2 handles them differently from DT 1, and so the developers have been adjusting timeouts and things like that in order to deal with the problems. ATSServer (Apple Type Services, IIRC) frequently causes problems with system and applications, frequently causing them to stop responding, in my experience. So there are a lot of interconnected things that could conceivably cause problems.

One thing you probably want to do is to Verify and Repair the database. It’ll probably find some orphaned files, which you can try to import again, and that will probably cause the application to stop responding, and so on. Whether or not it finds orphaned files, it might possibly find problems in the database that would cause you to see the problems you’re seeing.

You might want to import PDFs just a few at a time. If you don’t mind me asking, what sort of PDFs are you importing? Are they all from the same source? How long are they? How many words do they have? Do they open easily in Preview/Skim/Acrobat/etc? Any information you can provide, including copies if you can/are willing to provide them, would probably be helpful. If nothing else, I could import them and be able to say whether they are causing problems for me too.

Rest assured that this is not (in any way) normal or accepted behavior for DEVONthink. The developers have always been very conscientious about ensuring that their applications function very reliably.

</not affiliated>

Listen, if you want i can make a screencast to show you the phenomenon.
My pdf are almost all manual of science and paper of it : lot of text and image on it.

Clowny, you didn’t say whether you are trying DEVONthink 1 or DEVONthink 2.

In either case, after importing a large batch of new content to a database, it’s a good idea not only to run Verify & Repair, but also Backup & Optimize.

If you are encountering the infamous multicolored spinning ball during routine operations in the database, the most likely reason is that your computer has run out of free RAM. At that point, processes that require operations in memory are forced to use Virtual Memory, which requires swapping data back and forth between disk and RAM. Disk access is orders of magnitude slower than access in RAM. So a procedure that requires constantly swapping blocks of data back and forth between RAM and disk in order to run to completion will inevitably slow down.

The brute force solution is to install more RAM. if possible.

Other solutions involve making as much free RAM as possible to the database, especially at times when memory-intensive operations are planned. See Also, for example, can use a lot of memory in a large database. Try:

  1. Quitting and relaunching the DEVONthink application. That will likely free up some RAM.

  2. Quitting other applications that are using RAM heavily.

  3. Restarting the computer to “clear” previous allocations of data to Virtual Memory and start fresh.

But running out of RAM isn’t the only thing that can cause that dread spinning ball to appear. An errant process, perhaps some startup item that got stuck, or even Spotlight’s indexing of new content (which will stop when finished),can peg out your CPU resources and slow the computer down to a crawl. (Note that having a lot of active Widgets may result in use of a lot of your computer’s resources — RAM, CPU and even network bandwidth.)

I use a little Preference Pane utility called MenuMeters. It lets me install in the Menu bar current displays of RAM and CPU usage. I can see at a glance the status of my RAM and CPU resources. At the moment, with 10 applications open, including DT Pro Office 2.0 (with 3 open databases), I can see that well over half of my 4 GB of RAM is free of any encumbrances, and my CPUs are chugging along almost at idle. I’m very unlikely to see that spinning ball.

So, your systems aren’t hack-free after all (with MenuCracker that MM uses). :smiley:

Never said I have an absolutely stock OS X.

But I’ve been using MenuMeters for years without stability problems. My “Other” preference panes in System Preferences are limited to Growl, MenuMeters and PenTablet. The latter is definitely a hack, as I’m using a ModBook, a custom Mac tablet that includes a Wacom digitizer board with digitizer pen input. Axiotron, the manufacturer of the ModBook, has to patch standard OS X to recognize the digitizer board and GPS hardware. So far, so good. I’ve been using the ModBook 7 days a week for almost a year, with no problems.

Now that I’ve installed Microsoft Office 2008 on the ModBook, the weirdest Console messages I’ve seen resulted from an AutoUpdate run. nStack leaks all over the place. Oh, well.

I’m having the same problem. Just installed DTP2 and imported a 1.28 GB DTP 1 database. (I just noticed the size of the database DTP2 created is only 1.05 GB) I’ve found one PDF that when I select it I get the “awful multicolor ring” :smiley: and DTP2 hangs. CPU usage goes up to 99 according to my mac’s activity monitor before I force quit.

I ran verify and repair, however, it didn’t find anything wrong with this particular PDF. I assume there may be other similarly damaged files in my DB, but I just happened to come across this one. How can I fix it and how can I figure out if there are other files with similar problems? I realize DTP2 is a beta, is there any info I can send that might be useful?

In case it wasn’t clear in my rambling, I would really like to know:

  • how do I fix the PDFs that cause DTP2 to hang when I select them?
  • how do I find all the ones that I need to fix?

Is it really an DT problem? What happens if you export the PDF and then open it? Is it opening correctly in the OS X Preview?
Is the PDF file itself fine or is it maybe the troublemaker?

Specifically, it’s a DTP2 problem. This particular PDF was fine in DTP1. I assume something happened during the upgrade of the database when I moved over to DTP2. I backed up the original DB of course, but I’d like to try and move over to DTP2 now and this seems to be the only problem.

I can’t export it because I can’t select it without having to force quit DTP2.

You should be able to select and export such a file by first switching to a View that doesn’t display the file when selected, e.g., List view.

Does that exported PDF open properly in Preview (or Skim or Acrobat, if you have that on your computer)?

Now a procedure to confirm whether or not that PDF has some property that results in display problems under DEVONthink 2:

  1. Create a new, empty database whose sole purpose is to test that PDF.

  2. Close your other DT Pro 2 databases (in case you have to Force Quit during this experiment).

  3. Choose File > Import > Files & Folders and select the suspect PDF. Can it be selected and displayed, e.g., in Three Panes view? Can it be opened under Preview (if selected under List view)?

Can the PDF be displayed in DEVONthink 2? If there are database problems with this PDF, please send a message to Support that describes the problem and what you have done, and attach the PDF and (if present) a recent crash log for DT Pro 2 and DT Pro 1.x.

I didn’t even think of that! I have the one view I like and rarely switch to just a plain list view. :blush:

Giving it a try. Thanks!

I have this problem too. Just one pdf that consistently refuses to be imported without beachballing DT. It’s definitely a DT problem:

  • no other program is inaccessible
  • beachball only appears when mouse pointer is over DT
  • DT is marked “not responding” in Force Quit dialogue
  • pdf opens/behaves normally in Finder/Acrobat/Skim/Preview
  • I have 2Gb RAM in an almost new 2GHz Core 2 Duo MacBook

I’ve tried all the suggestions above, to no avail. It’s not that big a deal, as it’s just one document, but maybe for others it might be more than one.

Please, once such a PDF has been identified that chokes DEVONthink 2, attach it to a message to Support, with a brief description of what happened.

That could be very useful to the developers. :slight_smile:

Thanks, Mr DeVille! Willdo.

When I do a “Verify and Repair”, it detects that four documents are “orphans” - and they are PDFs (because I only file PDFs; however DT 2 PB1 freezes at that point.

Is there any other way to identify these files?