Devonthink Pro Office - Local Web Server iMac, iPad & iPhone

I have set up a local web server for Devonthink Pro Office and I can access the databases from Safari using the addresses found within;

preferences - server

Unfortunately (and frustratingly) I cannot access the same address’s using Safari from my iPad or iPhone. I have JavaScript enabled for both devices (iPad/iPhone) but this still does not work. I have also tried adding /iPad and /iPhone to each devices address for each device but this also fails to work, resulting in the following error message;

Could this be a firewall issue because I can access the address’s from my iMac that has the Devonthink databases installed but no other device?

Shaun

I have been looking within the Devontink manual on page 14 VERSION 2.7 say this has been fixed for Mavericks;

I am experiencing the same problem but both with and without a password. I have also tried accessing the through a PC but this results in the same error.

Anyone any ideas?

Current version of DEVONthink (all editions) is 2.7.5

If all devices are on the same local network and using Bonjour, the DEVONthink server should be discoverable at an address similar to this:


http://10.0.1.18:56408

I am able to access the DEVONthink server on any of my local wireless networks at an address such as that.

I have 2.7.5 its just the manual from Devonthink online support that shows 2.7 unless I’m using the wrong one?

I have managed to set up Internet access to a test database using the;

but this did not work for me;

and I had to substitute;

for;

Hopefully I have set this up correct, it looks to work fine and access from my PC web browser works.

On the local network perhaps its something I have not done correctly.
On my iMac within the Bonjour tab I can see Devonthink Pro Office and clicking this opens ```

http://xxxxxx.local.:xxxx/desktop/

Using this address works locally across all my devices but it looks different from the example you gave above.

I only have Bonjour installed on my iMac, do I need to download this for my PC, iPhone, iPad?

Addresses with formats like these are equivalent. One form uses the machine ID on the network, the other form uses the machine’s IP address. Both forms use the port where the server can be found.

http://MyPersonalCray.local:62172
http://10.0.1.18:62172

iOS is Bonjour enabled. Nothing extra is needed to run on iOS devices. It doesn’t hurt to install Bonjour on your PC – but only if you’re having no joy accessing the server on your local network.

You’re accessing the server over the internet? Then you have to use your machine’s public IP address (the “Step 1” address) and not it’s private address on your local network (the “Step 3” address.).

Caution: geekery: BTW, unless you have purchased a static IP address from your ISP ($$$$) then most likely eventually the internet link will quit working when the ISP recycles a router or otherwise changes your IP address – beyond your control. Just locate the new public IP address and redo the configuration. Or you could use a service like DynDNS (less money, but money) that will overcome the problem.

Think your right here. I’ve just come away from the office/router to test it works at Startbucks (coffee :stuck_out_tongue: ) and I cannot access the database over the internet. I will reset it back using step 1 and test again when out the office as unfortunately I didn’t bring a copy of the router IP…

so I have changed in back using step 1;

but this does not work for me and just times out.

The address I is http://xx.xxx.xx.xxx:port rather than http://xxx.xxx.xxx.xxx:port

Could this be the problem?

Sorry, I can’t guess at what the “x” is a placeholder for.

Addresses of the form 10.—.---, or 172.—.--- or 198.—.--- are all used for local networks and will never work anywhere over the internet.

Have your reviewed the tutorials for Server access in the Support Assistant (Help menu)?

Yes I have reviewed them and followed each line by line but cannot get it to work;

Local Network
Within Devonthink - preferences - server - starting server;

iMac - Address works
iPad - don’t work - Safari cannot open the page because it could not reach the server
iPhone - don’t work - Safari cannot open the page because it could not reach the server
PC - don’t work - times out

changing the address to

iMac - Address works
iPad - don’t work - username & password asked for twice then sticks on loading
iPhone - don’t work - username & password asked for twice then sticks on loading
PC - Address works

Very confused now…

Internet / web access

Step
1 - Have this for my router
2 - Is this the same port number used in step 4?
3 - Have this for my iMac
4 - Using suggested 8080
5 - Is step 2 & 4 different? I can only add;
name
start port
end port
protocol
IP address
6 - done
7 - cannot connect

Any ideas on this one ?

Internet / Web Access - Problem fixed :smiley:

This was the port forwarding settings, human error on my part. The port number I had selected was 4 numbers and I thought it should be entered like so;

Start Port: xx
End Port: xx

Turns out it should be like so :blush: ;

Start Port: xxxx
End Port: xxxx

Thanks for the input Korm. I just need to resolve the local network issue and I can start doing some actual work :mrgreen:

I used “findmyIP” website and inputted the correct setting within the firewall exceptions so now works over the internet and locally.

In addition I have settled for VPN software with 256 bit encryption. Gives me some coverage across all devices/Apps when traveling +using other networks. Will look at using this with the OSX Server VPN later