DevonThink Pro Office on a Server

I have DevonThink Pro Office installed on my Mac Mini Server (Mavericks). It works well under the admin account.

I would like to not have to log into the server as Admin to use it, as well as allow other users access without having them log in as Admin. I have attempted several times to create new user accounts, both Network and Local, and utilize the software. The software opens as it should, and will accept the registration key, however it will not open my database.

I continue to get an error that states the database is open by another user, which it is not. Even if I click Continue, the database does not open. I have tried adjusting permissions to the folder, and to the file. I have created a group and added the user to that group and propagated permissions. I can save and open other files in the folder. It is on a local HD. I can’t think of anything else to make this happen. Please help.


DEVONthink does not allow multi-User access. It is not a client-server application except in the use of the Web Sharing UI.


Jim, I clearly stated that DevonThink is installed on a single machine, a mac mini server running 10.9.3 and Server 3.2.1.

I also clearly stated that the database was closed by the other (Admin) user of the machine. In fact, it was closed, and even rebooted. The second user is a local standard user, who has full read and write permissions to the location of the database, as well as permissions to the database file itself. I get the same results accessing from VNC (Screen sharing) or access from the console.

The Database is only being accessed by a single user at any single point in time. Which is what I was told would work in my pre-sales questions.

The software itself opens as it should, however when attempting to open the database within the software I am given the “In Use” error even though it is not, and even when I continue through that error the database does not open, I get no further errors.


The “in use” message will be triggered by an attempt to simultaneously access a database by more than one instance of DEVONthink, OR by any event that improperly closes a database, such as an application or System crash, power failure, etc.

If a database fails to open when the “Continue” button is clicked, it may have become too damaged to open.

Ok, this may be the intention, but it is not what is going on.

There is nothing in the logs on the machine to indicate any system crash or improper shutdown. The database was closed through the menu system in the client, then the client closed. No errors were present.

Once I logged out the Admin, and logged in as the user, I got the message. I then logged out and back in as Admin, opened the database with no error, closed it again, and rebooted the machine. Logged in as the user, and same result, in use error message. At this time I attempted to continue, it would not open-- no error, no pinwheel, just not opening.

If you don’t believe me, schedule a time where you can remote in and observe. I am reaching a high level of frustration here as I have a large investment of time involved in what I was lead to believe a suitable solution. Being logged in as an administrator is not a suitable solution, as I have regulatory and compliance issues I need to be concerned about.


Thanks for the thoughts, but again, I don’t think these are factors. Application is not installed in users\username\applications, but in \Volume\Applications. The application itself opens fine under the user’s account. I have also attempted to create a new “user” with the same results. The Database is on an internal HD, albeit a secondary drive, but all users have read/write permissions.

I have not tried to move the DB to another machine, mostly because I don’t have DTPO installed on another machine.

I really wish I could get a serious answer out of the support team at DT. I simply cannot believe that this is acceptable support level on such a product.


Have you emailed Support with your query, or are you (only) referring to the comments made here, in this thread?

@JLModer2: Yes, please send a Support ticket request, with more information.

You should definitely be able to access a database from more than one user account on a computer (but not simultaneously). If you properly closed a database from one user account and attempted to open it from a different user account on the same computer, you should not have seen the “in use” message–so something else must be going on.

To work with the same database on a network, you should be using the Sync procedure.

There is a Ticket but it’s in Development now on an issue I discovered related to this.

chmod 777 the package and the contents and it shoudl work.

(Sorry for the late reply, I have been laid out sick. :frowning: )

Sorry to here you are ill.

I sent in another ticket tonight.

I can provide remote access to the machine if needed.

Thank you!


The forum is really only useful if people follow up with their solutions (if there are any). That is what makes it valuable to future visitors, who try to find ANSWERS (positive or negative, i.e. “this is how this gets fixed” or “there seems to be no solution”).

Did you try Jim’s suggestion with "777"ing everything in the DB package? Since bulk permission changes are un-undoable, you might want to create a duplicate of an existing DB of yours that displays the issue under investigation. Confirm that this new DB also doesn’t open, and then do the 777 on the package and its contents. It would be very odd if that doesn’t change things.

Please try this to ensure that the permissions of the complete package are the right ones:

  1. Quit DEVONthink Pro Office
  2. Select the database in the Finder and remove the .dtBase2 extension. The database will be a folder afterwards.
  3. Open the Finder’s Info panel for the database folder.
  4. Change the permissions (e.g. read/write for you & staff)
  5. Click the small lock icon in the lower right corner of the Info panel if necessary
  6. Choose “Apply to enclosed items…” in the action menu at the bottom of the Info panel
  7. Add the .dtBase2 extension again.