Devonthink + Sonoma + Clip

Hello,
I just upgraded to Sonoma and my issue is that when I use the Clip extension ([edit]Safari only it seems - Firefox now works) , the two dropdown “Format” and “Location” cannot be accessed (Format is stuck on “PDF” and “Location” on “Global Inbox”).

I don’t see anybody having an issue with this feature.

Can you please advise?
Regards,
Philippe

Do you use the current version 3.9.3?

Yes

Works actually fine over here, do you use the public release (14.0) of Sonoma?

Yes (tried rebooting also)

Hold the Option key and choose Help > Report bug to start a support ticket and include a screencast of the behavior.

Done

Hello @BLUEFROG

While resetting my configuration fixed the issue, it is now back. I recall adding back some scripts to my toolbar. Could that be the issue?

I wouldn’t suspect it’s related as the Sorter is a separate window.

@BLUEFROG - Sorry but I do not know this feature - can you tell me what I can change to test this?

Note that this seems to be somewhat random, it started working again 5 minutes ago.

Perhaps related, I noticed that dropping emails also works sporadically. For instance I just got [1] dropping from Mail. Yet I dropped it first in Yoink and could then drop it again into my group.

The Sorter is where the Clip To DEVONthink actions happen, just as you were reporting earlier.


There are plenty of bugs in Sonoma.
When’s the last time you did a Mailbox > Rebuild in Apple Mail

I was not clear sorry - I thought you meant the sorted could be “docked” or otherwise adjusted.

I just did a Rebuild and still have the issue.

However I also noticed that quitting/restarting DT fixed the issue for a while.

I guess I will wait for Sonoma to improve.

No worries!
Where are you dropping the emails when it fails?

I have tried with various groups. I used to use the plugin which I understand is no longer supported by Apple.

Hello,
FYI I also get an error[1] using the view/import mail.
If I quit DT and restart it, the import works

[1]

Is this part of your support ticket?

No the support ticket was on Clipping from Safari/Firefox … then I went into a tangent in this thread (my fault).

No problem. Can you open a new ticket on this issue so we can look at the current logs?

Hi @bluefrog - Perhaps that is what you meant here. I think I just got it: if Safari in on my external screen, the problem occurs. If Safari is on my main screen all is well.

I cannot reproduce right now and have updated DT to 3.9.4.
Will open a ticket if I see it again.