Devonthink To Go and external PDF viewers


I am currently testing out Devonthink Pro Office (DTPO) on my laptop ahead of purchasing it. I currently use the Papers app to manage my academic PDF library, and read the PDFs on my laptop using either Preview or Highlights. On my iPad pro I use goodreader and PDFexpert for reading and annotating my PDFs. I manually manage my library across the two devices.

I would also like to incorporate Devonthink To Go (DTG) into my workflow on my iPad Pro. If I import my pdf files in DTPO, I should be able to synchronize them with DTG and read them there. But if the pdf reader incorporated into DTG is anything like DTPO, I would probably still prefer to use other software to read and annotate my PDFs.

If I were to send pdf files from DTG to PDFexpert or Goodreader, would the standalone PDF reader apps open a copy that PDF, or the same one imported into DTG?

Does anyone have suggestions or feedback on how to manage a small PDF library with DTPO/DTG but continue to use other PDF viewers on the iPad Pro?



Hello Yazan,

you can send a copy to any app supported by your iPad for pdf from DTTG or send it by email or save it to another location. But what is the issue using DTTGs pdf reader as you can annotated your PDFs directly?

Just one tip:
If you want to annotated your PDF somewhere else, please note that this will be a copy of the original document. What you could do is to send it back to DTTG (Global inbox) after you annotated the document. By this way, it would overwrite the original document in DTTG.

Hope that helps.

Best regards,

this would work fine. Anything in DTTG is available in the Files app and can be “opened in place” by compatible apps (e.g., opened without creating duplicates). If you wanted to use PDF Expert or PDF Viewer on your iPad – both of which have Files app integration – you can just navigate to the PDF wherever it lives in DTTG using the Files app integration in the PDF reader of your choosing. Any changes you make are immediately saved to the file where it lays (in this case, it lays in DTTG).

If you want to use an app that doesn’t fully support open in place/Files, such as Notability or Good Notes, then you do need to do the round-trip rigamarole, but that’s a limitation/decision of those apps, and there’s nothing DEVONthink can do to workaround the decisions made by those developers.

I’ll second Scott’s recommendation.

For best results, don’t “send” files from DEVONthink to Go to other apps, if that app supports opening files from the DEVONthink hierarchy in iOS Files. That way, DEVONthink syncs the document correctly (please buy the app so you get the sync feature) and there is only one working copy of the file on your iPad.

For PDFs I recommend looking into LiquidText. It plays very well with DEVONthink to Go.

Unfortunately, the Files app is too buggy for me to use. For example, on my iPad Pro 2018, I’m in PDFExpert, choose iCloud, then iCloud Drive. Tap DEVONthink To Go, work my way down the group hierarchy to the desired target, a group of PDF files. There I get the list of files, only the list is incomplete. If I go to DTTG and look in the target group, I find a file I want to annotate, and it does exist on the iPad. Back in PDFExpert, the group’s file listing has that file missing. For a file that does exist, if I tap on it, it either opens in the PDF app and I’m good to go, or I get an error that the file can’t be opened, that it is corrupt. During another try of the same sequence, the file may suddenly open, but most of the time, I get the corrupted error.


Thanks for all the feedback!

Hello, I am a new user of devonthink to go and liquid text. These are the two apps I bought (liquid text first then devonthink to go) after I got the iPad Pro 11”. I am looking for help how to use them as a combo as my workflow to review pdf and file them properly for research project. Happy to see this recommendation on liquid text. I tried to send a annotated doc from liquid text to Devonthink to go, but didn’t manage to make them work. Basically, when I choose to export the notes outline from LiquidText from the share sheet, I tried both ‘clip to devonthink’, and ‘copy to devonthink’. I saw them files imported into devonthink database,but the content just didn’t shows. Once, it said, I can only open in liquid text, but I don’t quite get it. Does it mean that, if I want to open the file, I just go to liquid text to open it? Rather than, click in devonthink to go database and it will help me open it with liquid text app?

Can u pls advise what is your workflow in using liquid text and devonthink to go as a combo? I would really really want to learn. I don’t see many tutorial on this? I now start to use liquid text heavily for my research work, so making the workflow work for me, will boost my productivity. Pls advise.

The only workaround seems to be using the Files app.

This is a massive problem, as the Files app just cannot handle folders with hundreds of files.
It tends to just crash and require reboot!

Also, using DTTG, you want to use it’s search and then work with the results!
Therefor, proper “open in” support is, what is finally needed!

But nothings moves, the development of the most important things is just stalled.
This is massively frustrating.

Bluewings666, I also am a new user of Liquid Text. Fantastic program. But can’t figure out how to open files from the DTTG hierarchy on my iPad with Liquid Text. LT does appear to use the Files app for opening compatible files on the iPad, but how does one get to the DTTG hierarchy from there. It doesn’t show up. Perhaps because I sync DTTG with DEVONThink Pro on my Mac instead of on iCloud?
I second your request for a workflow that enables these two apps to work together.

1 Like

I just tried with LiquidText and it works like how I would use PDF Expert.

  1. Find the pdf file in DTTG
  2. Share to Copy to LiquidText
  3. Annotate file in LiquidText (I have the free demo, so all I did was highlight some text)
  4. Share as a PDF file to Copy to DEVONthink (don’t pick the Clip to DEVONthink)
  5. DEVONTHINK shows the annotated pdf file.

This test was performed on an iPad Pro running the iOS 12.1.4

Note that there is a copy left in LiquidText that you should delete to keep from having multiple copies of that same PDF file.

Hey mbarton98,
Thank you! I got it to work following your directions. I added one more step, number 2, for clarification to myself:

  • 1 Find the pdf file in DTTG
  • 2 Share to “Open in…” (bottom row of Share dropdown)
  • 3 Select “Copy to LiquidText” in Share dropdown (middle row).
  • 4 Annotate file in LiquidText (I have the free demo, so all I did was highlight some text)
  • 5 Share as a PDF file to Copy to DEVONthink (don’t pick the Clip to
  • 6 DEVONTHINK shows the annotated pdf file.

Very nice.

I had same problem so and then and corrupt happens when DT has not fully updated the file. A return to DT, sync and return to the application should solve the issue.

For files that appear grayed or cannot be opened, this happens because DT has not downloaded the file. Return to DT, make it available (open and close it from DT) and then will be available to other applications.

Said that, my preference is have a independent folder in iCloud Drive with all my “current” long edit/annotate files and move to DT when finished. That way the only layer is iCloud Drive. However, I’ve never had any problem on annotating a PDF in PDF Viewer (from PSPDFKit) from DT Files folders.

@JohnRobert that’s the old-school round-trip procedure. Not needed (or in my experience, reliable) with the current version of LiquidText.

  1. Make sure you have the current version of LT, on the current version of iOS, with all extra features purchased an installed.
  2. In the LT main page open a PDF from Open File, and be sure you are opening it from the DEVONthink to Go section of Files.
  3. Open the file.
  4. Make sure after annotating the document, use the Share menu (while the document is open), and choose Export to Reset Location. Set the Auto-Send Settings if needed.

This works for me reliably. I also have no problem with Files and DEVONthink. (Of course, I don’t try to cram 50GB databases up to DEVONthink to Go :smile:)

@korm thank you for the reply. However Files on my iPad Pro does not have a DTTG section. I speculated in an earlier post that the reason for this is that I do not use iCloud for sync with DTP. Instead I use Bonjour to sync DTTG on my iPad with DTP on my Mac. I prefer to keep sync out of the cloud since my Mac and iPad are usually on the same LAN. But whatever the reason, I cannot or do not know how to get a file for LT from DTTG through the Files app.
I will, however, try the return to DTTG using the Export to Recent Location command that you pointed out.
Any thoughts?

Probably has nothing to do with how you sync. When you open Files and press the “Edit” option at the top of the Browse column, do you now see the option to turn on DEVONthink as a file source?

More here.

1 Like

Son of a gun! There it is! :open_mouth:
Thanks, korm. Now I’ll give your method a try.

by the end of the process, your database full of duplicates.

I am not sure if I’m missing something here, but when I access a PDF within DTTG from the Files app and mark it up (bookmarks, whatever) in PDF Expert, the changes do not transfer at all to the PDF in DT. I don’t quite understand why that is. If I double-click that PDF in DT, for instance, it opens in PDF Expert and absolutely none of the bookmarks I added to the PDF in PDF Expert on the iPad are there. If I open the share sheet on the iPad and open the PDF in PDF Expert, the bookmarks remain.

What I really want to be able to do is add my bookmarks, etc. to the PDF on my iPad and then go back to my Mac for further processing in DT. What is making these bookmarks not translate to the desktop version (everything is synced so there should be no issue)?

Post-script: I forgot to add that if I take the opposite route (i.e., opening the PDF in DT with PDF Expert on the Mac), the changes, added bookmarks, etc., sync over to the DTTG version. So I don’t get why the opposite doesn’t work.

Might have something to do with this.

1 Like

Well that explains it. Haha. And I’ve also found Readdle to be less than responsive when contacted, so who knows when (or if) this will ever be fixed. Bummer.