DEVONthink Unresponsive for Over an Hour - Spinning Beach Ball of Death

Hi all,

I’m experiencing a critical issue with DEVONthink that’s affecting my ability to work. I’ve been trying to open the application for the past hour and a half, and all I’m getting is the spinning beach ball of death.

What I’ve Tried:

  1. Initial Attempt: When I first tried to open DEVONthink, I was met with the spinning beach ball, making the app completely unresponsive. Tried to force quit and reopen several times at intervals of ~15-20 mins.

  2. System Restart and Update: I shut down my computer, and it ran an update. After rebooting, I tried to open DEVONthink again, only to encounter the same issue.

FYI I’m running Ventura 13.5.1 on a 2018 Macbook Pro


  1. Could this be related to space issues on my computer?
  2. Age of computer?
  3. Is it possible that my DEVONthink databases have grown too large, causing the app to become unresponsive?

Any help or guidance would be greatly appreciated, as I need to resolve this issue urgently to continue using DEVONthink effectively.

Update: the app did finally open, but as I tried to take any action, it would only remain functional for ~10 seconds before going back to beach ball

Re 1: what is the size of your disk on the computer, and how much of it is “free” and available? To help resolve clear out Trash in both DEVONthink and the file system (in case there is a lot there).

Re 2: Unlikely. 2018 for a Mac is not unusual. Unless there is some sort of hardware flaw.

Re 3: Unlikely, unless there is insufficient disk space to support what you call “large”. DEVONthink databases are not monolithic and can grow much larger than you may think.

As it’s hard to debug this sort of issue here, I’m guessing @BLUEFROG will invite you to send in a Support request via the Help menu (press Option key to see).

It might be worth running a utility like Onyx: Titanium Software | Operating System Utilities for Mac - OnyX


Not that it’s a contest, but I can beat that. I’ve had DT be unresponsive overnight. The issue for me, per Support, was that some large video files were added to an indexed location. DT was stuck indexing and checksumming these files. (Apparently it doesn’t skip files when that operation makes no sense.) The situation was made more difficult because there’s no way to stop an operation in progress. In my case the only route to recovery was to disconnect from the drive where the files were stored so that DT no longer saw them as being present.


Just wondering. Were you deliberately indexing the video file(s) into DEVONthink?

How would it decide that indexing and check-summing a large file makes “no sense”? I’d assume the sensible cause of action is to handle all files equally, so that users are not risking data corruption and can search their content.

@rmschne why would I deliberately do that?

@chrillek Well, not so much “large files” just file types that have no searchable content. Altho if performance in a known issue, which it appears to be for a non-cancellable operation, skipping or delaying files above a threshold size might make sense.

:wink: As some people here say they want to index video files, I was just checking and that would have been my next question!! Cheers.

  • Where is the database located - the file path of it?
  • Are you indexing files into it?
    • If so, from where?
  • How large is the database in terms of words/unique words in File > Database Properties?
1 Like
  • Where is the database located - the file path of it?

    • All databases are in Macintosh HD/Users/[myusername]/Databases/
  • Are you indexing files into it?

    • Yes, many
  • If so, from where?

    • 2 external hard drives, mostly, as well as one Dropbox folder
  • How large is the database in terms of words/unique words in File > Database Properties?

    • The main database is “Words: 274,765 unique, 21,058,388 total”
    • Work database is “Words: 76,566 unique, 10,321,970 total”

@rmschne FYI, I am deliberately indexing large video files from an external hard drive that is only sometimes connected. It’s for the purpose of linking to specific times in meeting recordings (and all the other awesome DT capabilities) but not having the ability to store those important videos locally.

30 GB of 500 free. I cleared out both system and DT trash per your post. I regularly clear out system trash, but realized that I rarely clear DT trash. Thanks for the reminder.

@mbbntu Thank you, I will check this out!

@GordonMeyer Thanks for the insight. What would happen if you force quit DT in that situation?

I am finding myself having to do that quite a bit, most often to eject a hard drive that wont do so “because DT is using it” as it says in the dialogue box. Often times, though, I made no changes to the files, just connected to watch some media or something, and then could not eject the drive, so I end up having to force closing DT to disconnect the HD.

There is quite a bit of media on each of the two main external drives that I connect… assuming that is probably relevant.

If you’re indexing them into an active database but not connecting the drive, why don’t you index into a separate video database that you only open when you connect the drive?

Also, if the beachballing recurs, please do this…
Open a support ticket.
Do a Spotlight search for Activity Monitor. Select our application in the list of processes - it should show “(Not Responding)” and the name in red - and press Command-Option-S to run a sample on it. When the sample window opens, press the Save button and save it to your Desktop. Please attach this text file to your Support Ticket so we can inspect it. Thanks!

Ahh, interesting. Ok, I’ve started the process and eliminated ~150 GB of indexed items from that drive. To have to content available in the relevant folders, I’ve grabbed a DT link to the large item(s) in the new video DB and placed the links in the relevant folders in the main DB. Let’s see!

Sounds good, thank you Jim.

You’re welcome :slight_smile:

I had no idea DEVONthink even could (or would?!) “index” video files. What the what?!

It’s not indexing in any magical way, i.e., it is not getting the text from it.

Ok, I’ll bite: what does DEVONthink “index” from video files if not some magical text (or perhaps subtitle *.srt file?) extraction process?

metadata. Nothing magical.

1 Like