DevonTP does not work with ScanSnap S510M

Last week I mentioned on this list server that my Canon M830 scanner did not work with Devonthink Pro after installing Leopard. I also mentioned that Image Capture does not work with Leopard either. However, I wanted a faster scanner than the Canon 830 anyway so, as there was no sign of trouble with ScanSnap on the Devon Trouble Shooting List Server, I purchased a ScanSnap S510M.

I was assured by everything I read in the Devon literature that DevonThink Pro would work automatically with ScanSnap. I got the ScanSnap S510M today and like my Canon 830 it works fine with its own software, but it does not work with DevonThink Pro.

When I started Devon up it detected that I had a ScanSnap scanner connected and asked me to install the DevonThink Pro driver, which I did. When I tried to import a scan into DevonThink Pro from the scanner, it couldn’t see the ScanSnap device. It then asked me to Browse for the scanner with Image Capture, but it couldn’t find the ScanSnap scanner either. It comes back with “No device connected or no scanner detected.” So Devon on startup detected ScanSnap but your driver cannot see the device.

I cannot find any way to select the ScanSnap scanner driver in DevonThink Pro.

As a test, since I still have Tiger on one of my drives, I loaded the ScanSnap software on Tiger and again it worked fine with its own software, but after DevonThink Pro detected the ScanSnap scanner and I installed the Devon driver, Devon could not find the ScanSnap S510M for a scan. Image Capture could not find it either. “No device detected.”

So, am I missing something fundamental here or is there something fundamentally wrong with your drivers.

~ leep

Yes, you missed something. :slight_smile:

Simply set ScanSnap Manager’s Application tab to DEVONthink Pro (the name of the DEVONthink Pro Office application, using the Add or Remove button). Once that has been set, ignore any prompts in DT Pro Office asking if you wish the setting to be changed to DT Pro Office. It’s already set.

Now all you have to do is insert paper copy and press the Scan button on the ScanSnap. The scanned PDF image will be sent to DT Pro Office and it will be OCRd and saved to your database.

If you use File > Import > From Scanner DT Pro doesn’t see the ScanSnap, because the ScanSnap doesn’t have a driver ‘hook’ to Image Capture. That’s OK.

My CanoScan LIDE 500 F has two ways of sending PDFs to DT Pro Office. One involves DTPO’s File > Import > From Scanner - Capture routine. But the one I prefer uses, like the ScanSnap’s driver, the Canon ToolBox software that can be set to send a PDF to DT Pro Office. Then DT Pro Office runs OCR and saves the PDF to the database. In this mode the scanner is controlled by Canon’s software.

Note: I’ve upgraded to Leopard and am testing a beta of DT Pro Office 1.3.4. Everything is working, so expect the update pretty soon.

But ScanSnap works under version 1.3.3.

Thank you Bill for the quick reply, that solved the problem.

It’s too bad that DT Pro doesn’t include the info you described in their manual or in the pop up info screen after DT Pro detects ScanSnap. In fact, the pop up info tells you to turn off the ScanSnap Manager which leads one to think that DT Pro is taking over the scanning duties rather than using the ScanSnap Manager. After rereading the manual I see that I should not have jumped to that conclusion.

The ScanSnap Manager defaults to its Menu settings when first opened and the Application settings are not even available and easily missed. Applications can only be activated by turning off the Menu mode which turns on the Profile mode which in turn allows one to add DT Pro. Easy when you know how, but not obvious to a neophyte.

Again, thanks for the quick response. You guys really support your product and that is greatly appreciated.

~ leep

Just for the record, Help > DEVONthink Pro Help does have instructions on the ScanSnap if you search for OCR. The ScanSnap is “unsupported” for capture via File > Import > From Scanner… (I prefer the “unsupported” mode to Image Capture.) See excerpt from online Help:

If your scanner isn’t supported by Image Capture, don’t worry. As long as you are able to scan somehow, for instance, by using the scanner manufacturer’s application, there’s a way to get your documents into DEVONthink Pro Office.

First, check if your scanner uses one of the following scan applications:

Avision ExactScan (in the works)
Apple Image Capture
Canon ScanGear
Epson Scan
Fujitsu ScanSnap Manager
HP ScanPro

If your software is in the list above, you just need to tell it to send the scanned file to DEVONthink Pro Office (in the HP software this feature is scalled ‘scan destinations.’ Most scanner applications allow you to do change this setting (for instance, when opening scanned images automatically in Preview, Adobe Photoshop, or The GIMP.) Change the setting so that DEVONthink Pro Office is your application of choice, and scanned documents will open in DEVONthink Pro Office.

As soon as your scanner application sends a scanned file, DEVONthink Pro Office will automatically run optical character recognition on it and then save the file to the currently open database. If DEVONthink Pro Office doesn’t run OCR automatically, please contact us. We will see if we can add support for your scan software to future versions of DEVONthink Pro Office.

I have exactly the same problem. I cant get DTP to recognize my scansnap scanner. Initially when I launched DTP it recognized that i had the scanner and asked me if I wanted scanned documents to be directed to DTP. I confirmed that I did but it still doesnt work.

I tried the fix suggested by Bill, but the “applications” tab in the scansnap manager software is grayed out, so I cant do this. Any suggestions ? Or do I just have to wait until on DevonThink and Leopard compatibility ?

Suggestions ?

Sometimes flaky behavior such as misbehavior of the Applications tab in ScanSnap Manager results from some sort of temporary memory error and can be cured by simply restarting the computer to clear out cobwebs. Try that.

If the Applications tab in ScanSnap Manager’s settings remains grayed out, I would suspect something is wrong with your operating system – some third party software conflict with ScanSnap Manager. It’s not a problem with DT Pro Office itself, as version 1.3.3 has some other Leopard problems but works well with the ScanSnap to receive, OCR and save PDF from scans.

Have you installed (or left installed in an Upgrade installation of Leopard) any OS X hacks to the operating system such as add-ons to Safari, “other” System Preferences Preferences Panes, an Unsanity haxie including APE, Input Manager plugins in the Input Managers folder of your User or Boot Volume Library folder, or third-party QuickTime plugins to modify audio or video performance?

If you have installed software that modifies the behavior of OS X, try removing those items to see if problems go away.

There are a great many “add-ons” that hack OS X to change its behavior. Some do things that users like. But there can be a risk in modifying Apple’s carefully designed code, with the possibility of flaky or unstable behavior. So I always urge caution about OS X mods.

An OS hack that worked in the previous version of OS X may turn evil when Apple introduces a new operating system such as Leopard. The hack is trying to patch an area of code that has changed, and errors can result. Check with the developer to see if there has been an update.

By the way, watch the forum and Eric’s blog for a notice of Leopard-compatible revisions of the DEVONthink applications and DEVONagent, with a download link to the revisions. They will be announced Thursday, November 15, 2007.

Thanks for your reply Bill.

I did a clean install of Leopard, and have only installed the standard software stuff, nothing out of the oridinary. I have tried to re-install both DTP and Scansnap Manager. I did install Adobe Acrobat 8 Pro that came with the scanner, together with FineReader for scansnap. That is about it. The version of DTP I am using is the demo version. Could this have an impact ?

Is there a way to get DTP to offer me the option of using ScanSnap again ? It used to come up at start-up, but doesnt anymore.



K, you don’t control ScanSnap scanning from DT Pro Office. It’s controlled from ScanSnap Manager for settings, and then one presses the physical Scan button on the scanner.

Try removing the FineReader software, as it doesn’t need to be installed and may be competing with DT Pro Office’s IRIS OCR module.

Adobe has announced initial compatibility problems under Leopard for Acrobat 8.

You need to have the Settings in ScanSnap Manager open, and access to the Applications tab. Choose DT Pro (Office) as the application to which the scan is to be sent. Launch DT Pro Office. If a message appears offering to change the setting, check the box telling the message not to bother you again, then press the Ignore button.

Put some paper copy in the scanner’s feeder, and press the Scan button on the scanner.


I have uninstalled DTPO, scansnap and all associated software, I have reloaded the beta release of DTPO for Leopard. I have re-installed scansnap manager (only). Still the applications tab is blanked out. Do you know where I can get human help support for scansnap ? Very frustrating.

Okay, I have solved the problem, For the record, in case others encounter this the “use quick menu” option in the scansnap manager must be disabled in order to access the “applications” tab in the settings. Then DevonThink Pro can be selected as the default application.

Thank you Bill for your patience. You are a star in deed.