Disable RenderMarkdown Hidden Preference


I turned on the hidden preference to render markdown by default, found that I could no longer edit the markdown file, and tried to turn it off. I ran:

defaults write com.devon-technologies.thinkpro2 RenderMarkdown -bool NO

But there was no change. I deleted the file


But there was still no change, DEVONthink is still rendering markdown by default. How can I turn this off?

Try -bool FALSE.
Also, was DEVONthink closed when you ran the Terminal command? It should be.

Tried -bool FALSE as well, same result. I did quit DEVONthink before changing the setting.

I just quit DEVONthink, opened Terminal and pasted defaults write com.devon-technologies.thinkpro2 RenderMarkdown -bool FALSE. Selecting a Markdown document after relaunching opened in Edit mode, not rendered.

What OS and version of DEVONthink are you running?

Ah, you know what, I posted this in the wrong forum and didn’t even notice. I’m running the beta, I’ll move the conversation down there. Mia culpa.

Ahh… that may be it. No worries.

Independent of the preference setting issue, what do you exactly mean by “could no longer edit the MD file”? Generally, you have to toggle the “text alternative / best alternative” icon in the toolbar right above the preview pane to switch between rendered and editable mode. Are you not aware of that procedure, or are you saying that in your installation this toggling does not work?

I was not aware of that button, thank you! This is sorted just fine for me now, actually.