Documents only on iCloud to save storage on iPhone

Dear all,

Is it possible that I delete all the data that I transfer to the iCloud with DTTG on the iPhone afterwards locally on the mobile phone? My goal is that all documents are stored in the iCloud and downloaded on the mobile phone if necessary, so that they do not take up any storage space on the iPhone, because I remove them locally again after reading them.

So only the entries of the documents that are stored in the iCloud remain on the iPhone.

It seems that all files will be downloaded automatically to the iPhone after having deleted them locally even if I selected “download manually”.

What do I wrong?

Many thanks in advance.


It’s unclear what you’re describing and where you’re seeing this behavior.

Hello Jim,

Sorry, I just wanted to keep a long story short. But here is the full challenge:

I maintain all documents on Devonthink on the Macbook. On the road, I use DTTG on the iPhone and sync via iCloud (CloudKit).

For some time now, I’ve also wanted to give my wife the option of accessing documents from the same database on her iPhone. But since she has her own iCloud account, the synchronisation does not work with my MacBook.

Therefore, I first transferred all files to her DTTG app (setting Load files: always) on her iPhone via Bonjour. Then I uploaded the data to her iCloud via CloudKit. Now I switched the Load Data button to manual and deleted all files locally to save storage on my wife’s iPhone.

At the same moment, the app starts downloading the deleted files back to the mobile phone.

I had hoped that my wife would not have to carry the files around on the mobile phone, but could download them as needed. That’s exactly how it works on my iPhone. Why not on my wife’s? What am I doing wrong or is the idea described too absurd?

Thanks in advance.


No worries!

Actually deleted the files or purged them?

I am not a native English speaker, so I have just a clue of the difference between delete and purge. I use the German version of the app, which has two options. The first is called „löschen“ (delete) and the second is called „lokal entfernen“ (remove locally).

What I selected was remove locally.


lokal entfernen should remove the contents of the files, though it won’t completely release all the stored data on the iOS device.

At the same moment, the app starts downloading the deleted files back to the mobile phone.

Can you post a screen capture of where you’re seeing this?

Hello Jim,

Please see my screen shots. The setting is los manually. However, all files are downloaded back to the iPhone.

In the Info popup for the database, what do you have Download Files set to ?

Thank you, Jim, we are one step further. The switch is indeed set to “Always”, unfortunately I cannot change to “Manual”. Unfortunately nothing happens, I can’t change the slider.

  • Is the CloudKit sync location the only one you have?
  • Did you just now set the sync location to Manuell or was it set that way?

Apart from Bonjour, there are no other sync locations, but the MacBook, which works as a “server” for the iPhone (client), is switched off.

The switch was set to manual. I did not change it, I only learned through you that this option even exists under “Information”.

What is Download Files on the the Bonjour sync location set to?


The problem is solved. In fact, the switch on the Bonjour sync location was still set to “Always” and not to “Manual”.

After having changed this, the switch in the database could also be moved to “Manual” and only the selected documents are loaded.

This is how I wanted it.

Thank you for this ingenious product and the excellent support.

Best regards,


Excellent! Fortunately, most problems are simple and logical to solve.

And yes, having two sync locations with mixed settings would indeed cause you to not be able to set the a database to a shallow sync.

You’re welcome and thanks for the kind words and encouragement.