doesn't support Chinese after upgrading to Leopard


after upgrading to Leopard, DT doesn’t support Chinese language. When I use “new + with clipboard”, it doesn’t work. But old notes in the database display right.

do I need to do something?


Samuel, make sure you are using the current release of your DT application, as there were rich text problems under Leopard with the posted releases as of the initial release date of Leopard.

In the DT application’s menu bar click on and choose Check for Updates.

We do want to hear about problems with Chinese or other Asian languages. If you have a text sample that isn’t properly handled, please attach it to a message to Support.

My Os version is 10.5.1 and DEVONthink Pro Office Edition is 1.3.4.

You can try to clip these website “” and “”.

When I use Scripts Menu, DT works right.( “add selection to DT” and “add text to DT” is same, I can clip the text,but can’t clip the image.). But when i copy and post, or drag the selections to DT’s icon, DT doesn’t work right.

Facebook 详解 (17033个读者)
原作者: wikipedia 译者: 雷声大雨点大 (Blog) 发表时间:10/06/2007 原文链接

when i copy and paste these into DT, It display like that

{\fonttbl\f0\fswiss\fcharset0 ArialMT;\f1\fnil\fcharset134 STHeiti;\f2\fnil\fcharset134 STXihei;
\f3\fswiss\fcharset0 Helvetica;}

\f0\b\fs36 \cf2 Facebook
\f0 'a0’a0
\fs26 \cf3 (
\fs36 17033
\f0 )
\fs36 \cf2

\f2\b0\fs24 \cf4
\f0 : wikipedia 'a0
\f3 \cf0 {{\NeXTGraphic div.gif \width20 \height220
\f0 \cf4 'a0
\f0 : {\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\f2 \cf5 \ul \ulc5 'c0’d7’c9’f9’b4’f3’d3’ea’b5’e3’b4’f3}} {\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\f3 \cf0 \dn12 {{\NeXTGraphic 4.jpg \width960 \height960
}¬}}} ({\field{*\fldinst{HYPERLINK “”}}{\fldrslt \cf5 \ul \ulc5 Blog}}) 'a0
\f3 \cf0 {{\NeXTGraphic 1__#$!@%!#div.gif \width20 \height220
\f0 \cf4 'a0
\f0 10/06/2007 'a0
\f3 \cf0 {{\NeXTGraphic 2
#$!@%!#__div.gif \width20 \height220
\f0 \cf4 'a0 {\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\f2 \cf5 \ul \ulc5 'd4’ad’ce’c4’c1’b4’bd’d3}}

\b\fs2 \cf2 \cb6


\b0\fs26 \cf2
{\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\f2 \cf5 'cf’d4’ca’be’c3’bc’c5’fa
\f0 (0)}}
{\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\f2 \cf5 'cf’d4’ca’be’d4’ad’ce’c4}}
\b \cb1

\fs2 \cf2 \cb6


\f2\b0\fs26 \cf2 \cb1
\f0 '93Facebook’94
\f0 Facebook
\f0 2%
{\field{*\fldinst{HYPERLINK “”}}{\fldrslt
\b \cf5 Facebook
\f1 'c6’f4’ca’be’c2’bc}}
\f0 Facebook

\f3\fs24 \cf0 {{\NeXTGraphic fb_hq.jpg \width5000 \height4000

Interesting. I copied and pasted the Chinese characters into my DTP and they worked fine.

Still more interesting. I loaded the referenced Web page and copied it to the clipboard, then created a new rich text document in DT Pro Office. Also did the same for some of the pages linked in the first page.

Some rich text captures came out fine, with Chinese characters and any images included on the Web page, some were ‘garbled’ text.

Are we perhaps seeing different text encodings used on different pages?

I checked this using Japanese (as I assume it would be a unicode problem rather than a problem specific to Chinese characters) and it works fine. I have a lot of Japanese texts and they display ok. I also tried pasting in some text from a web page to a new rtf and that was ok. I also did a paste using the dock clipboard option as well as an archive of the page. Both worked fine.
I also tried your page and I could again import using the above methods with no problem. Just a thought but when you upgraded to Leopard did all the Chinese fonts go into the fonts folder?

I was able to reproduce the issue at least sometimes and will look into this.

I am experiencing Chinese data loss. I cannot say when the problem popped up because I have not attempted Chinese entry in several months. At that time I was using DevonThink Pro 1.4x and Tiger.

Now I am using DevonThink Pro Office 1.5, MacOS X 10.5.2. It seems that my Chinese text from months ago is displaying properly. But new text disappears. Specifically, if I paste Chinese text from Word 2004 or input it directly into an rtf file in my DevonThink Pro database, the Chinese will display correctly. However if I then save the database, quit DevonThink and reopen that database, the just inputted Chinese text is nowhere to be found. where the Chinese should be, there is nothing (not even blank characters). If there were Roman letters in the original input string, those remain intact.

this is distressing as I have years of Chinese text towards my Ph.D. in my database and am terrified of losing it. Has progress been made since the last post (12/07) in resolving this issue?

To my previous post, I can add that the problem occurs in RTF.

If I create a New Plain Text and input Chinese, the Chinese is preserved after a save-quit-open sequence.

V1.5.1 (coming soon) will fix such issues once and for all.