Double amount of disk space when iCloud sync still not solved in DT 3

I installed DT 3 on a completely newly setup laptop with then synchronizing with the databases on my iCloud, But again when I checked the disc space of my computer I got the same problem. I have all the databases on my computer consuming 150 GB and then I have another 130 GB used by DevonThink in the Mobile Documents folder in the library folder.

So unfortunately the problem was still not solved. Who else has this problem?

Please DevonThink team, try to solve that really really annoying problem. I know the answer, that this is due to Apples iCloud Sync. But as obviously more users of DT have the same problem and other software that I use does not consume double the disc space, there must be a solution. Please try to solve that issue with Apple. As constantly running out of disc space when using DevonThink is a real problem. I really love the work that you do with DT, but if this problem cannot be solved, I cannot use DT for my business anymore.

Thank you very much for your help.


Did you download your databases via iCloud to the laptop? However, so far I couldn’t reproduce the problem - neither after up/downloading complete databases nor after verifying sync stores.

Yes I did. Shall I delete the iCloud storage and sync option and the apps on the iPad and then try again?

I tried to reproduce this yesterday but couldn’t, the local iCloud data was “evicted” (that’s how Apple calls this) as soon as possible after up/downloading or verifying databases. It shouldn’t be necessary to reinstall any apps or to remove sync options but you could try to clean the sync store & upload the database(s) again to see if that’s going to make a difference.

I will try it again. But for now I have another problem. I was deleting the iCloud DevonThink data as recommended by the support team. Then I was clearing the cloud storage in DevonThink. Then I waited until all the data of DevonThink in the iCloud was erased. Then I switch on Syncing in DevonThink again and I was marking the checkbox for a databases. But the upload process first produced a message in the log window saying that 1 item could not be uploaded. And when I tried another database it just froze at one point and there seemed to be a try to upload a file for 2 hours !!! So I quite everything, reinstalling a TimeMachine backup and starting from the beginning. Pretty annoying. As the databases are pretty big, like 16 GB and the upload time is long, I did let my laptop upload it over night. If the monitor is going into sleep mode, but the computer is still running, can this cause some problems ???

Thank you very much for your help as I start to get really frustrated.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

No, the monitor doesn’t matter, only the computer has to be awake.