“Download on demand” files won’t download in DTTG3

I am trialling DTTG3 (v 3.0.3) as long-time user of DT and DTTG2. So both DTTG2 and 3 are installed on my iPad, synching with Mac databases using iCloud (Legacy).

I have nine databases synched, one set to “Always Download” files and the remaining 8 set to “On Demand”. This set-up has always worked as expected in DTTG2, and continues to work.

With DTTG3 I can access the files in the “Always Download” database, but none of the files in any of the “On Demand” databases. The indexes appear to have been synched correctly (e.g. the database Info panel shows the same number of files and database sizes). When I select a file, though, I just get the blank screen with the file type and the download link greyed out. Tapping the Download link has no effect at all. Alternatively, pressing the Move icon and then selecting the “Download” menu item there produces a “Couldn’t download document” error message.

I’ve checked that the files I can’t download in DTTG3 continue to be available in the DTTG2 and DT databases

What’s going on here? Is anyone else seeing this? Any clues on how to fix it?

  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.

Thanks for getting back to me. No there isn’t a triangle.

But this made me realise what the problem is – I hadn’t set up the Sync Location in DTTG3! Because it had pulled in my existing databases and their settings from DTTG, I’d just (stupidly) assumed it had inherited all the settings etc. and was ready to go.

So totally down to me, as usual. OTOH, I do have a suggestion for the developer – it might have been a tad friendlier to have got an error message saying “Can’t download document because you have not set up a Sync Location” rather than just baldly say “Couldn’t download document"

You’re welcome and I’m glad to hear you got this resolved. Your suggestion is noted.

@BLUEFROG I am using Cloudkit sync for DTTG v3 latest version. How do I set sync location?

I also tried to use the download button but nothing happened. Guess it is also related to sync location not defined yet and the sync so far is only for metadata?

Sync locations are set in DEVONthink To Go’s Settings > Sync: Locations. Do you have no sync locations defined there yet?

I had set up via Cloudkit but download on demand not working. I ended up deleting the DTTG3 on ipad and the icloud database. Now re-syncing. Seems working now, but it is a painful process having to restart from scratch again

Perhaps you didn’t actually need to delete and reinstall DEVONthink To Go.

If it recurs in the future, open a support ticket. Thanks.

@BLUEFROG , appreciate the advice and support. I also discovered there were a lot of errors occurred during the re-sync. See attachedsync errors on 8 Apr.log.zip (1007 Bytes)