Drag/Drop Bug from DT3 to Chrome (Office 365 OWA)

I am using Chrome Version 100.0.4896.75

When I try to Drag/Drop a file from Devonthink to a web app in Chrome (such as to attach to Office 365 email) Chrome does not recognize the file.

This happens with DT3 3.8.3.

Drag/Drop works fine from Finder or other apps to Chrome

Drag/Drop works fine from DT3 to Safari

Has anyone else encountered this?

I assume DT has Full Disk Access? (I’m sorry, I’m not using Chrome, so I cannot test the behaviour; as such, my feedback is nothing more than a stab in the dark.)

Yes DT has full disk access

I experimented a bit more

The same problem happens on both my desktop and laptop Mac

It happens even if I revert to an older reversion of Chrome

The common thread appears to be when I try to drag/drop from DT3 to Office 365/OWA Email i.e. when I try to attach a file from Devonthink to an Office 365 email. Can anyone else who uses Office 365 see if you have the same problem?

Dragging and dropping to what - directly into the email draft in the browser?

Yes I am trying to drag/drop into the email draft in the browser

For years I have successfully done this with DT3 - now it stopped

Actually what happens is a bit intriguging - it pastes ** Content ** from the document into the email rather than attaching the file itself to the email.

It works fine if I use Safari instead of Chrome to attach a document to email

It works fine if I use DT3 and Chrome to attach a file to some other webapp such as Monday.com

It only fails to work with the combination of trying to attach a DT3 file as an Office 365 email attachment using Chrome

It only fails to work with the combination of trying to attach a DT3 file as an Office 365 email attachment using Chrome

That doesn’t surprise me at all considering Microsoft broke inter-application communication with their “New Outlook” for the Mac version of Outlook as well.

I’d opt to use Safari instead if you’re going to use a web interface to access email.

That may indeed be necessary

I guess I will have to explore how many of my Chrome extensions work with Safari

That said - any idea why this happens with DT3 and not with Finder or other apps?

Data dragged and dropped from apps isn’t a universal thing, i.e., there’s no standard for what data is included. And the receiving application interprets that data in its own way, so behavior can be different in that aspect as well.

1 Like

I don’t know if this is the same issue, but passing along the tip here in case it does help: I can’t drag and drop to Microsoft Teams (as Jim said I think the issue for me here is Microsoft being annoying). What I do now instead is drag and drop to my desktop (Mac Monterey), then drag and drop to Teams. That works and doesn’t inconvenience me. Drag and drop from desktop to Outlook still works too (I’m running the “old” version of 365 Outlook as the new version is missing so many features :angry: - downside to that is search no longer works in the old Outlook. Why do you do this, Microsoft!!!).

1 Like

The workaround to Drag/Drop to the Desktop and then to Teams or OWA does work - thank you.

I just realized there is another similar workaround which also works and is slightly easier:

In DT3 you can right-click and choose Show in Finder. From that Finder window you can drag/drop to OWA.

Yes, but you must be very cautious when inside the database’s internals.

Treating it as read-only is fine, i.e. drag/drop from the database but not to it.


We generally tell people to stay out of the internals unless instructed otherwise by us.
And yes you should never drop files into the internals manually. That will create inconsistencies, I.e., orphaned files in this case.

Is there any risk from dragging/dropping FROM the database as I suggest?

Or is your concern simply that I might accidentally make some edit in the database finder window?

Have you tried using a shelf app like Yoink?

1 Like

Very interesting - thank you for that suggestion.

It does indeed work perfectly with Yoink (which was sitting on my computer unused via SetApp).

That would work well as a workaround.

Though the mystery continues… Drag/Drop works fine from DT3 to Yoink and works fine from Yoink to OWA. Yet it does not work from DT3 to OWA. Why?

1 Like

You’re welcome, and I am glad that it worked for you. I am guessing that its the way these shelf apps capture the links. Will keep an eye on this thread in case the mystery unravels :slight_smile:

There’s no danger dragging and dropping from DEVONthink.

There is potential danger dragging in the Finder window.

1 Like