Dropbox sync authorization error

Hi all - I have been using Dropbox to sync my global inbox and one DT Pro database. This morning, every time I tried to sync, a browser window opened requesting that I authorize DEVONthink Pro to access its folder on my Dropbox. If I clicked Authorize, I returned to DT Pro, but a few seconds later, another browser window opened, apparently ad infinitum (I stopped after 10 requests). The sync did not proceed.

I canceled it, went to Dropbox, verified that DT Pro was authorized to access data, and then deauthorized it, thinking that reauthorization might solve the problem. It did not. I then deleted Dropbox as a sync location and then added it back, which had solved other sync problems before. Unfortunately it didn’t solve this one; I got the same repeated request for authorization by Dropbox. I did, nowever, get this error:

9:58:28 AM: Sync: Inbox → ogilvie@history.umass.edu (Dropbox) The operation couldn’t be completed. (CJSONDeserializerErrorDomain error -11.)

I verified that my other authorized applications can sync with Dropbox; it’s only DT Pro that is having a problem.

Any insight as to the cause of this problem, and whether it is on DT Pro’s or Dropbox’s side? Thanks for your time and attention.

We’re getting a number of support tickets this morning for this issue. Nothing in the Dropbox code in Sync has changed in well over a year at this point, so it seems to be on Dropbox’s side. This is not the first time that it has happened and Dropbox seems to resolve it eventually.

You might be able to force reauthentication with the following procedure:

​* Open /Applications/Utilities/Keychain Access.app

  • Search for OAuth
  • Delete the OAuth and OAuth Secret Tokens and quit Keychain Access.
  • In DEVONthink’s Preferences > Sync, delete the Dropbox location and re-add it.