DT 3.91 Editing PDF documents not working anymore

Just try:

x-devonthink://preference?key=ForceEditablePDFs&value=yes

NO joy

And did you open this link, e.g. via Safari’s location bar?

No, I have run a via terminal.

How do you „run“‘a link via terminal? That makes little sense. Just copy/paste it into Safari

1 Like

Sorry, I am still confused. How do I enable the hidden preference?

I have followed the instructions, but how do I know if it has actually been enabled?

Thanks for responding, Cris - understood.

Corruption of a PDF is the greater inconvenience (for me at least).

1 Like

Select a PDF that was marked as read-only. Is it now editable?

1 Like

Hello everyone, I’ve just bought the app after completing the 30-day trial and I’ve been quite impressed with this app so I built my nowadays workflow around it. So when I found out that the editing of PDF on MacBook wasn’t working as expected (I thought it was secondary to the automatic lock smart rule (because 30 days have gone by after putting the documents in DT3 and it seemed logical to think that because I was able to edit newer documents). However, after deleting the smart rule DT3 didn’t let me edit the PDF as I was able before in the old documents while still being able in the newer ones.

I don’t know if it was related to the smart rule or not, or if it’s a problem from Apple, DT3, etc. What I wanted to say, apart from describing my particular problem regarding the editing of PDF, is that after running the above link in the safari with DT3 fully closed it seems that it’s fixed.

I also think that it’s worth mentioning that I was able to edit such PDF documents in DTTG in the iPhone and in the iPad, so it looks like it’s something related to the app itself (DT3). Just my reasoning. I hope it’s easily and rapidly fixed.

In spite of the troubled start after buying the app, I’d like to thank all the dev team behind DT3 and DTTG.

Welcome @jcasanga and thanks for the nice comments!

The issue stems from a safety method built into DEVONthink to try to protect certain PDFs. We are modifying the detection code to minimize false positives. Stay tuned for a future release and thanks for your patience and understanding.

2 Likes

I don’t want to hijack this thread, but was referred here by Chrisitan Grunenberg.
Admittedly I almost forgot about (hidden) preferences.

  1. If I remember correctly one could enable / disable these from the terminal. Is this still true?
  2. Toggling the preference in the help menu interface does not seem to work either?

I’ve tried to read then write (to enable) but it seems to throw an error saying that the domain/default pair does not exist.

What am I missing here?
Thanks for helping out!

erwin@MBPi9-1 1 % defaults write com.devon-technologies.think3 ForceEditablePDFs -bool TRUE
erwin@MBPi9-1 1 % defaults read com.devon-technologies.think3 ForceEditablePDFs            
2023-07-03 13:38:26.669 defaults[96590:4958495] 
The domain/default pair of (com.devon-technologies.think3, ForceEditablePDFs) does not exist
erwin@MBPi9-1 1 % defaults read com.devon-technologies.think3 ForceEditablePDFs

There’s a section in the manual’s appendix entitled “Hidden preferences”. Does that help?

Chrillek,

Thanks, but no that does not really help. For clarity I have attached a screenshot. I would assume that once enabled the particular property would be “read” -able, but it keeps throwing that it does not exist.

As a work around I am using my old High Sierra that still has a working copy of PDFPen Pro. There I can just simply drag pages in to the thumbnail section, so I can do what I want to do.

It’s unfortunate to loose so much time searching.
Thanks for helping out anyway!

The code you posted works for me (Ventura):

> defaults write com.devon-technologies.think3 ForceEditablePDFs -bool TRUE
> defaults read com.devon-technologies.think3 ForceEditablePDFs
1

Are you sure your DT version is 3.9.1?
Clicking the links in the online help does indeed not work anymore, as @BLUEFROG mentioned in another thread.

Yes, my version is 3.9.1. Running Monterey 12.6.1.

And did you quit DEVONthink first?

Version 3.9.2 improvements worked for me, DT no longer marks my PDF as read-only even without enabling ForceEditablePDFs. Thank you!

DT no longer marks my PDF as read-only even without enabling ForceEditablePDFs .

Correct and thanks for the confirmation.

Do we have to disable this setting?
If yes, please provide brief instruction. - TIA
Or is the setting now obsolete?

Instructions about hidden preferences are provided in the manual. Help menu, type “hidden preferences” in text field …

1 Like