DT actions not working

I am not sure what is wrong, but I am no longer able to use the actions button to add a URL or PDF to DT from DA. I get that little ‘beep’ sound when I try. I tried restarting both programs, but it didn’t change anything. I cannot highlight a selection, and right-click it to add a selection to DT either. Currently the only way for me to get anything from DA to DT is via the Services menu.

Reinstalling DA/DTP (and logging out & in again) might fix this issue. In addition, ensure that both of them are located in the folder /Applications and there are not multiple instances of them on your drives.

I’ve followed the various threads on this issue and still can’t get DT services to work. Logged in and out, reinstalled, looked for extra copies of DT apps, still the system error sound when using DT services. Scripts and automator actions work fine.

I would appreciate any links or info on how I might explore the “corrupted services” theory, or any other ideas.

In general, while I love and appreciate the flexibility of multiple roads into DT, the app really could use some bomber universal input shortcuts. It would really lower the bar for new users, and make life easier for intermediate users like myself.

Other “junk drawer” apps like Yojimbo, etc have more easy and reliable default content capture from various apps. There’s a certain kludginess to having to find applescripts that work and assign them shortcut keys … what I want is to hit F8 or some other definable universal hotkey and have it automagically save whatever I’m looking at (wherever I’m looking at it) or a selection within it if there is selected content. Text, email, html, pdf, whatever - 1 button. I’d use the scripts if I needed to be particular about format, or naming.

Currently, I have to use separate scripts for various content types (html, pdf, etc), and have even had to fumble my way through applescript modifications to get them to work.

More bookmarklets (that capture pdf’s, webpage html rather than archive, etc) would also be appreciated since I’m usually trying to capture online content.

Thanks for any help,


First off, which web browser are you using? Since it sounds like you are using the services menu, I’m assuming Safari or omniweb because Firefox doesn’t support the Services menu. But if you are doing alot of web “hunting and gathering” into DT, I would suggest DEVONagent.

There is a free program called service scrubber, and you can tailor the Services menu complete with assigning shortcut keys. This may help your issue a bit I hope.

It’s not a shortcut key, but you can use Quicksilver to give you keyboard access to anything on the Services menu. Install the Services Menu Module.

My two favorite ways to get things into DT are Quicksilver, and right-clicking on the DT Dock icon.


Julian, what browser are you using? Some browsers don’t support Services.

I make hundreds of captures from Web pages every week. For fast, efficient captures from the scientific journals and other sources I routinely visit I use DT Pro’s built-in browser with the convenient contextual menu options to capture a rich text note (my preferred capture mode), the HTML source or a WebArchive.

DEVONagent provides similar contextual menu options.

Thanks for the quick replies. I am using Safari, which is still my preferred browsing mode due to various tweaks and its excellent tab handling. The DT browser doesn’t cut it for me for web research, DA’s browsing is better but still has a tendency to open up new windows, and so on. Maybe I’ll get used to browsing/searching in DA.

Since uninstalling DT, logging out, reinstalling, logging out/in, I now am able to use services without an error sound but it’s not sending anything to DT, sadly.

What I’m also hoping to see in DT Pro 2 is a context menu option in non-Devon apps …

For now I’ll probably use keyboard shortcut applescript triggers (thanks for the ideas though - I didn’t know about adding from clipboard in the dock icon menu).

hmm, there definitely is something wrong then. You should be able to capture a rich note from Safari by highlighting the portion and using the Services menu, or by using the Bookmarklets.

as to your problems with DA—have you set your preferences for tabbed browsing to only open new tabs?

Julian, just as a check:

Both DA and your DT Pro application must be in the Applications folder for Services to be active.

And there must be an open DT database in order to receive data from DA. So either DT Pro must already be open, or it must be configured (either in Preferences or in Database Properties) to open with a default database.

thanks, and yes, all of those conditions are true. that’s why I wonder if this if more of a system maintenance/services corruption issue. i can’t find anything reliable or safe-sounding as far as fixing that possibility, though.

what I like about safari is that it can force everything to open in new tabs. in DA, even with open in new tab prefs selected, new windows seem to open up anyway. I’ll try the “block popups” preference.

thanks again,

Julian, do you do routine operating system and disk directory maintenance?

For example, I always run Apple’s Disk Utility repair permissions and verify disk routines before downloading any Apple OS or Security update, and afterwards always run the repair permissions routine.

There are a number of maintenance routines that can be run from the Terminal. But it’s convenient to do that with a utility that runs them with a better GUI, or that runs a number of them automatically (like AppleJack).

Personally, I use AppleJack (Google it) and/or C ocktail (which is much like the donation-ware utility OnyX) to run periodic maintenance operations (usually weekly, or anytime I see flaky behavior), and DiskWarrior to keep the disk directory cleaned up and optimized. Almost every time I run DiskWarrior (every couple of weeks or so) it finds and corrects some small errors that, if left unchecked, could eventually cause me problems.

And I’m cautious about downloading programs that I’m not familiar with or haven’t checked out, especially anything that modifies the operating system.

My attitude is that it’s much more dangerous to not run periodic maintenance, than to run maintenance utilities that I’ve checked out and perform well for me. (That doesn’t mean that I use each and every option provided in those utilities. For example, there are advanced features in AppleJack that shouldn’t be touched unless you know what you are doing; but the routine features are safe.)

I got used to holding command when clicking links, which open them in a tab, and I don’t even think about it any more. There are still the odd links out there that will open a new window no matter what, but these links do it for every browser.