DT crashes immediately upon opening!

What the hey! This morning when I tried to open DevonThink, it immediately crashed.
Anyone else experiencing this? I haven’t applied any updates or made any changes to the database.

Do you use the App Store version of DEVONthink Personal? The installation seems to be broken, maybe due to an automatic update? Reinstalling the application should fix this. Another possibility is to use the free-world version (see devontechnologies.com/download) which recognizes App Store purchases.

I am having the same issue on DTPO.

Do you use the latest version (2.9.13)? Updating should fix this.

I am not sure what version I was using. However I downloaded the new version and installed it replacing the existing app, and the issue is resolved.

When reporting crashes or application freezing, it’s best to use the hold the Option Key and choose Help > Report Bug. It’s also best if you have determined the crash is reproducible and the steps to reproduce when possible. Thanks!

I had the same problem with devonthink pro. Downloading the latest version and replacing the existing app fixed the issue but I am sure that I already had the latest version of the app running on my computer before.

Add me to this problem

Again - this has already been reported here as well as on our blog.

I had the same experience this morning with DTPO 2.9.12. It worked fine yesterday. The only thing that happened between then and now if that I shut down my computer. Will download 2.9. 13. Here’s the diagnostic:

Process: DEVONthink Pro [1261]
Path: /Applications/DEVONthink Pro.app/Contents/MacOS/DEVONthink Pro
Identifier: com.devon-technologies.thinkpro2
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: DEVONthink Pro [1261]
User ID: 501

Date/Time: 2017-07-14 13:09:54.573 -0400
OS Version: Mac OS X 10.12.5 (16F73)
Report Version: 12
Anonymous UUID: 1895BBA3-7BE1-3C37-0050-F9A2243E7A83

Time Awake Since Boot: 5400 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
__TEXT 0000000101823000-0000000101a2e000 [ 2092K] r-x/rwx SM=COW PboardType

Thread 0 Crashed:
0 ??? 0x000000011056a000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007fff5e3dcc60
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000011056a000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x101823000 - 0x101a2dfff +??? (0) <119218DC-C0C2-3CF8-AA39-4B001E4E96D4> (null)
0x110569000 - 0x1105a6dc7 +??? (433.5) <322C06B7-8878-311D-888C-C8FD2CA96FF3> (null)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 4339
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=2548K resident=0K(0%) swapped_out_or_unallocated=2548K(100%)
Writable regions: Total=8404K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8404K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 2
__DATA 704K 5
__TEXT 2340K 3
shared memory 8K 3
=========== ======= =======
TOTAL 67.2M 12

Model: MacBookPro13,3, BootROM MBP133.0226.B23, 4 processors, Intel Core i7, 2.7 GHz, 16 GB, SMC 2.38f7
Graphics: Intel HD Graphics 530, Intel HD Graphics 530, Built-In
Graphics: Radeon Pro 455, AMD Radeon Pro 455, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x80CE, 0x4B3445424533303445422D45474347202020
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x80CE, 0x4B3445424533303445422D45474347202020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x15A), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.4f18, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6


DTPO 2.9.14 has solved the problem.

Yep. As advertised. :mrgreen:

Well, looks like I’m not the only one to experience this!
I downloaded/replaced as recommended, and the problem was solved.

Odd that I was (or thought I was) running latest version already!

Same issue.

Deleting the app and reinstalling seemed to fix the problem.