DT hangs in one simple text

A strange thing occurs in one rtf-abstract I am typing in DT: at exactly the same spot in a line, DT hangs, the spinning wheel occurs, and all I can do is Force Quit DT. At first I believed I had erroneously pressed some key combination, but I have repeated it now for about 10 times (I still have the text, because I "grabbed" it before Force Quit). I have added other files, tried again, no luck. What is going on here?


OSX 10.2.8, PB/G4

I have since discovered that the same problem occurs in TextEdit. Whatever words I add, after about one added line DT, DN or TextEdit hang. The text is not very different from many others I have added, and still add, to DT: some colours, some Hebrew, rtf.

This suggests that the problem is not related to DT but to a bug in Apple’s text-engine. Any comment appreciated.

(Using OSX, 10.2.8, soon to be replaced by Panther)


Could you send me the text? Then I could check this over here (e.g. if it’s related to your system or Mac OS X 10.2.x). Thanks.

Many thanks for the offer - but I found a workaround by editing the text in Tex-Edit Plus, which worked fine, and reimported it to DT (as RTF). That also worked. Alas, I deleted the old file. But as I said, I do not think it was related to DT, as exactly the same problem occured in TextEdit.

Interestingly, Tex-Edit Plus is a Carbon app.

DEVONthink and TextEdit use both the Cocoa text engine, Tex-Edit probably uses something else.