DT not indexing new files

I just migrated to an M1 Macbook Air. MacOS 11.2.3, DT 3.6.3. Now DT doesn’t seem to be indexing new files.

For example, select one of the newly added files. In the view window select and copy a text string. Paste the string into the search box. DT can’t find the file.

I tried “Update Indexed Items” but it doesn’t fix the issue. Is there a way to resolve this?

Welcome @Dan23

A screen capture may be helpful.

(I increased your trust level so you can post one.)

Here is a screen shot showing the string selected in a document:

And this one shows the string pasted into the search box:

DT says no items found.

That file is listed as a PDF Document, therefore it hasn’t been indexed by DEVONthink.

  • Try Data > Convert > to Paginated PDF. Does that resolve it to a PDF+Text file?
  • Where did this file originate?

Tried the conversion, but that didn’t make any difference.

Also, note that other programs such as Spotlight and HoudahSpot have no trouble finding the text string in that file.

Booted up my old Intel MacBook. Same versions of OS and DT. Copied the file over and DT immediately located the file with that string.

The files in question were scanned in with my Fujitsu 1300i scanner.

DEVONthink isn’t using Spotlight for searching. It has its own indexing and search engine built in.

Make sure you local backups are current and do a File > Rebuild Database on the database on the problematic Mac.

Started the rebuild on one database. It’s been importing for an hour and it’s on 37 out of 4249 items. At this rate it will take almost 5 hours to finish. Something must be wrong! Is it normal to be so slow?

Edit: math error. It’s going to take almost 5 DAYS

Is there perhaps a hardware problem? I know the machine is new, but … try a Disk Repair with OSX’s Disk Utility?

Read this:

I think it is your problem.

1 Like

I ended up reinstalling DT. Restored one database from a backup and had DT reindex the folder for another. Everything seems to be working again.

Apparently, something had broken during the migration to the new laptop.

1 Like