DT pop-up document viewer won't remember zoom-to-fit

When I open a PDF in DT’s separate document viewer, I like to use “zoom to fit” so that I can see the whole page without having to scroll. When I close the document viewer and open another document, I have to do it again - it won’t remember my preference. Is this expected behaviour, and is there any way to get DT to remember my preference?

This may help (from p 39 of the user guide (also available through the in-app Help)):


In addition to many common contextual menu items there are also a few PDF-specific options:

Automatically Resize: When checked, the zoom factor adjusts to the width of the view/edit pane or document window.


Hi @Stephen_C - thanks for your reply. But I don’t see those options in the context menu when I right-click a PDF. Do I need to look elsewhere?

Try using the context menu in the viewing window for the relevant pdf.


“Automatically resize” appears to be selected already when I check the context menu in the viewing window:

If I change the “single page continuous” to “single page”, then the image fits the screen like I want it to. But if I close the viewer window and then reopen the PDF, it reverts back to “single page continuous” - it doesn’t remember my preference.

Ah yes, sorry: I confirm I see the same. I guess that it’s just not bothered me so I’d not previously noticed the issue you mentioned.


Well, thanks for trying to help anyway! @BLUEFROG or @cgrunenberg, would value your expert advice here! :smiley:

Did you change the preference in Preferences > Files > Multimedia or just the currently used settings via the contextual menu?

The latter. The former fixed it, thanks! Question - is it possible to have this default setting set per database? For example, for one database the zoom to fit might be best, but for another the full width zoom might be best.

No, it’s a global preference.

Would be a nice feature to have - may I put in a request?

The request is noted, with no promises, of course.

1 Like