DT Pro 3 Beta and Alfred

Hi! I switched to the DTP3 Beta and it’s awesome! But with DTP2 I could search and find all files with Alfred. This does not work anymore. I enabled the Spotlight Index of my Databases and the Files are found with Spotlight, but not with Alfred. My databases are located in ~/Documents and this folder is in Alfreds Scope. As it worked with DT2, is there anything that changed here?


Alfred might have to be updated, I’d suggest to contact its developer.

I opened a Forum Thread there too: https://www.alfredforum.com/topic/12522-devonthink-3-results-in-alfred/

You might have to add the folder ~/Library/Metadata/com.devon-technologies.think3 (version 2 used ~/Library/Caches/Metadata/DEVONthink Pro 2)


Jepp, that’s it! Adding this folder to Alfreds Scope lets me find the files again. Thank you!

For some reason, this isn’t working for me. When I type "Devon " in Alfred to trigger the search, it looks like it’s going to work – but when I type my search term, Alfred defaults back to a Google search for the term “Devon [my keyword].” Any idea why this might be happening?

1 Like

I looked at integrating Alfred with DEVONthink 3. I had some issues with getting the search results show in Alfred even with these instructions. I tried to send the question to the thread in Alfred forum, but then it demanded some registration (?)

Anyway, in Alfred you limit the locations and file types to focus the search. In DEVONthink 3 it seems that the metadata folder holds files of type *.dt3, that relate to the actual files in the DEVONthink database/no.index. So I added the *.dt3 file type to the Alfred search, and then it worked. Any comments if this is the “proper” way to do it with the current DEVONthink 3? This way the files show as “DEVONthink” documents, vs pdf documents, etc.

Message to Alfred forum:

"I’ve created a system of DEVONthink 3 databases (latest version), and now (after some break) I’m looking to adding Alfred to my system. So I added the ~/Library/Metadata/com.devon-technologies.think3 directory to the Alfred search scope. However, it didn’t work straight out with me. When I looked inside this metadata directory, it had files such as DCB46528-5156-4085-927C-8DB846B13556.dt3inside it. The actual files it in DEVONthink databases reside in some location like ~/Databases/Database.dbBase2/files.noindex/..

So I added the .dt3to Alfred file types to search, in addition the the ~/Library/Metadata/com.devon-technologies.think3 scope. Then it started to work."

If that workaround does then job, then fine. FWIW, I’ve found that the Spotlight indices created by DEVONthink 3 frequently are not found in Spotlight itself, on Catalina. The Catalina Spotlight index seems to get corrupted easily and frequently and need rebuilding. For some reason, the Spotlight indices built in database preferences for each database are rarely searchable on Catalina.

I’m also on Catalina, and this way to do works with Alfred for me at least for now. I’ve been rebuilding my database structure lately, such as moving the databases inside encrypted vaults. So far I’ve found the files in the databases with Spotlight fairly regularly, but they often show up the name as “DCB46528-5156-4085-927C-8DB846B13556.dt3” instead of the actual file name, though at other times it has showed the name properly.

Apple has made some fundamental changes in Spotlight… and not necessarily for the better. We also think these changes may have trickled down into Mojave as well. :confused:

Searching with Alfred works for me. However, if I search for a PDF in my DT database which was downloaded from a website (so it has the url in the meta data), it doesn’t open the file in DEVONthink but the website. Any ideas how to fix this?

Btw, I had to add to Alfred’s scope the file type “com.devon-technologies.metadata.think3”, otherwise it didn’t find anything.