DT3.3 View>Columns> - bug?

On View>Columns> (alternatively right-click on the toolbar above a preview), Size is not on the list but Size is one of the columns on the preview. Is that bug or if not then how do I remove ‘Size’ from the preview columns?

Choose View > Columns > Customize Metadata…, is the size disabled in this panel?

Yes disabled. I attach screenshot. Also screenshot of the view columns

I just enabled it then quit DT3.3 then opened again. Size appears in the Column list. But then when I disabled it, quit DT3.3 and opened again, Size no long appears in the Column list, but it does appear as a column.

I just realised I was using a save workspace.I wonder if that workspace saved the fault. How do I revert to the default workspace so I check?

The workspace doesn’t include this configuration. It’s possible that the last setups of some databases still use this column, the next beta should fix this. In the meantime I’d suggest to enable the column and to remove it manually.