DT3.7.2 Markdown WYSIWYG Editor with text between dollar signs


I noticed a strange problem after the 3.7.2 update.

Current config:

  • macOS Catalina10.15.7
  • DEVONthink 3.7.2
  • Plain Text Font: Menlo

In the md Editor, with WYSIWYG editing selected, any text that falls between dollar signs eg. $500 is grey $400.

Screen Shot 2021-05-22

I closed all my DBs and emptied cache. Then created a new md file in Inbox with no DBs open and got the same result.

Any md syntax between the dollar signs is ignored. See image.

All md syntax renders correct before and after the two dollar signs in the Editor.

There are no unusual invisible characters.

Preview mode is working and renders all md syntax correct.

Don’t you just love a puzzle…

Appreciate any help

What happens if you escape the dollar sign(s) thus:


or even:



This is almost certainly detected as a mathematical expression.
We’ll have to look into this.


Your suggestion to enclose the text with $ some text $ works.

This is helpful to getting closer to a solution.

Maybe I need to change some setting somewhere.


This is surely related to LaTeX symbology.
Not, it only affects the WYSIWYG source, not the rendering. The only setting that would affect this is to disable WYSIWYG.

I don’t use LaTeX. Is there somewhere I can check this setting or disable it?

The only setting is the one I mentioned. And it doesn’t matter if you’re using LaTeX or not. It’s being detected as a mathematical expression.

Thanks much BLUEFROG and @mksBelper.
Understand the WYSIWYG md much better now.

Take care

1 Like

You’re welcome.

The next release will improve WYSIWYG in case of disabled MathJAX support.