DT3 beta deletes files when indexing external folder

I use DT to index my folders as external ones. All is smooth in DT2. But when I try DT3 beta1, several error logs prompt. Some files are not recognized by DT3 and are moved to Trash. Then if empty trash, the files are moved to macos recycle bin!
I think when I index folders as external ones, that means I don’t like to touch the original files. So this design puzzles me.
Could you please check if it’s a mistake or you just change the design?

Due to the tighter filesystem integration (stuff is now synchronized in both directions, e.g. renamed, created, moved, copied and deleted), indexed groups and their respective folders are now always consistent.

Therefore it’s not possible anymore to remove items from indexed groups without removing the actual files/folders as this would break the consistency (and DEVONthink 3 would soon readd them anyway).

Removing indexed items without enclosing indexed groups still prompts you whether the indexed files/folders should be removed too as in version 2 though.

1 Like

Then why should DT3 move the error-prompted files to trash automatically? I think it should be tagged or something instead. It’s a dangerous design.
And the error-prompted files CAN be opened by MS Office. They’re not recognized by DT3. I found no error in the files.

It should only after Data > Move to Trash or after using the “Move to Trash” contextual menu command of the Log panel. Did DEVONthink 3 move the items right after indexing to the trash without using the above commands? And to its own trash first or right to the Finder’s trash?

I just tried to reproduce this by creating a broken Word doc but the item was only indexed and an error logged as expected.

I use neither of the two commands. Log panel shows up and I just close it. DT3 trash the broken index items to trash in DT3. Not the Finder’s trash. But I think it’s a dangerous design. If I empty the trash in DT3, the files end up in Finder’s trash. And I cannot put it back if I don’t know which subfolders are these files originally exist.

I hope you’re being wise and using test databases for DT3 testing. :confused:

Well, I’m not that wise😔 for I believe the external indexing should not touch the original files. But I’m wise to have backups in both Time Machine and Dropbox.

for I believe the external indexing should not touch the original files.

That’s the essence of indexing though, leaving the files in the external location and working with them instead of copies in the database.

Also, for years people have been asking for tighter integration so changes made in DEVONthink are correctly reflected in the Finder.

Could you send some of these files to cgrunenberg - at - devon-technologies.com? In addition, do you already use any custom smart rules?

I sent an example file. And I don’t use smart rules.
I’m not a pro user of DT. I use it just as a more powerful index & search engine for my files now.

This is only tangentially related (apologies): how does a DT3 deal with a DTTG file saved to an indexed group? I’m guessing that the file doesn’t get automatically moved to the corresponding filesystem folder—just making sure.

Like in version 2, it’s not moved to the filesystem folder.

1 Like

in relation to this issue, it happened some days ago… in DT2.

I purchased a new NAS, faster enough to use it as file repository instead of having files in different clouds, then I moved all my indexed stuff into the NAS. I went to my main DT2 installation and re-index the files now from the NAS network drive.

In the meantime I received the fast M.2 caché disk and installed it in the NAS as read cache.

Suddenly, my second Mac started corrupting the files stored in the NAS when it was matching the downloaded sync stuff with the network drive files (DT2 shows screen and slow and painfully go across al the files). While doing that the corruption started. (If you wonder why I detected that in real time, I was monitoring the cache disk inside the NAS tool and saw 0% of caché hits, and looked at the file system and saw how at the same time the file was being shown in DT2 screen, I saw it half its size in the NAS file explorer).

I immediately stopped DT2, corruption stopped happening and started investigating the issue. I’m not sure but the combination between the NAS read cache, plush whatever DT2 do to the stored files (date changes by moments and then returns to the original date), plus the immediate backup in the cloud of the NAS caused the corruption.

I couldn’t get more details, but asked some NAS expert forums and most probable cause was the triple access to the file, that some NASes doesn’t handle multi access well (Yes, I was very surprised as well, mostly when comment was done by a developer I know from a different manufacturer of my NAS model). Since I’ve delayed the NAS synchronization with the cloud only on nights, corruption never has happened since.

All of this come because the problem ern had could be related to things like this. Since I’m using DT3 in three Mac, no corruption o other strange things have happened, and I have a lot of indexed files.

(BTW, yes, since I lost all my source code many years ago caused by broken Iomega Zip disks, all my stuff is backed up at least twice in different platforms/physical support).

That’s indeed interesting. Sounds like some NAS devices are intended only for single users.

However, at least mine (Synology DS1019+) supports any amount of users, and others like QNAP or Asustor do it as well. It worries me a little bit, but until now and except the counted situation, Synology never failed to me, even one day really really saved my ass because I have Recycle Bin enabled for most important shared folders, and has some kind of “historic” deleted files.

Well, I deleted the database file and re-create one. After index the same folder, this move-to-trash action disappeared. So I cannot reproduce the problem now. Or should I say it solved itself?
After all, thanks for all your time.

Same thing started happening to me. If I drag-drop a file (.docx and .py were tested) into a particular folder (indexed by DT3), it is immediately moved into the “Bin” (Catalina lingo). If DT3 is not running and I do this, DT3 fires up and the file is moved to Bin. Apologies if I didn’t quite understand the above discussion re. indexing, but il looks like that some kind of “folder action” or I-don’t-know-what is attached to this folder by DT.

I’m running macOS 10.15 and DT3.0.1.



If drag & drop onto a folder in the Finder launches DEVONthink, then at least one folder action is attached to it. Or do you use Hazel?

Yes that was it. DT Import&Delete script was attached to the folder. Thanks.