DT3 Bug - Convert Plain Text to Rich Text

Hey, I tried to convert Plain Text files to Rich Text in DT3 and the resulting file was a blank RTF. Tried the same in DT2 and worked perfectly.

Not seeing an issue in the current internal beta I am running. If you want to ZIP and post a file that’s not working, I can test it here.

I rectify. Tried again with a single file and apparently the resulting RTF is not actually blank, but has both a white background and white text. Might be related with the Dark Mode affecting by default Plain Text’s background (black) and font color (white) Vs. not affecting RTF background (white).

The result of the conversion was the same white font, but over a white RTF background (invisible). Any way to change the font color in batch?

Thx and sorry for the false alarm.

Does it appear correctly when switching off the dark mode color scheme?

I’ve had a few anomalies like this. Quitting and restarting DT3 has corrected it in every case. If it happens again, what would be the most helpful route for sending useful troubleshooting information to the DEVONTechnologists?

Also, you may want to try deleting the app prefs.

  1. Quit DEVONthink.
  2. Open /Applications/Utilities/Terminal.app and paste: defaults delete com.devon-technologies.think3 and press Return.
  3. Type: exit , press Return and quit Terminal.
  4. Relaunch DEVONthink.

I have a similar problem. Type text into a “Plain Text File” as illustrated below.

Then I convert to RTF format using the “Convert” menu item. What I get the following which looks like a blank document with white background.

It’s not of course as the text is simply white on a white background.

Not clear to me is why this is a default behaviour of DT3 Beta 3 in my case and how to change this default setting.

Did you switch Preferences > Editing > Plain Text’s font and background colors?

Not conscientiously in any case. However I just followed up on your suggestion and as far as I can make out the settings should be correct e.g. white text on dark background (see screenshot below):

Beta 4 will fix this.