DT3 encrypted database error

beta 7 and a bit disturbing. Planning on moving back to DT after a long time away. Created an encrypted database to hold all of my sensitive financial records. Good. Moved all of the documents into it. Good. Closed DT last night before going to bed. Good. This morning I start DT and it gives me the warning that the database is open by someone else (impossible since the computer was turned off all night). Database will not open at all via open menu, via double clicking in Finder, etc. No errors shown anywhere. Not good.

Restored from a Time Machine backup from last night (please no lectures on backups…I have multiple of those as well so was able to recover easily from this scenario regardless) . DB would not open either. Had synced with iCloud and brought a copy down and that worked. Created new regular database and moved everything there. Removed three other encrypted databases and replaced with regular ones because I don’t trust your encryption system anymore.

I realize this is a beta but DT3 is what you guys are shoveling to customers now via the website like its a final product. Is there some logging I can turn on, etc. to see what was happening with that DB since no errors were being generated?

It’s actually not our encryption, it’s just an encrypted sparse image (identical to those that can be created via the Disk Utility.app too). Which maximum size did you specify for the encrypted databases? Ideally it should be very large as the it’s a sparse image and therefore uses only as much disk space as necessary. Finally, please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com - thanks! Maybe the logs contain additional hints.

Christian first off apologies as my posting was a bit too harsh. Shouldn’t have been.

I do know (pretty sure mentioned in the docs) that its just an Apple sparse image. After I posted I did a bit more experimenting. I changed the name to .sparseimage to try to just mount/open in Finder. That also didnt work as I first got a ‘resource busy’ error. I then went into Disk Utility and oddly enough there were two copies of the file mounted. Unmounted both of those. Double-clicked on the “broken” one in the finder which then shows up as mounted in Disk Util (not in Finder yet tho). Did a repair which was successful then remounted in Finder and it worked. I can now see the DT database inside.

I created the image as 1gb and there is about 900mb of data in it. Seems like that should have been OK but clearly need to make it bigger than 1gb.

Keep wondering why it showed up as “in use” when I first started the machine this morning. Wonder if it was showing up as mounted in Disk Util at that point. Unfortunately I can’t time travel :wink: but it makes sense that for some reason it wasnt fully dismounted last night. At any rate I will redo with larger files.

So looks like DT might have been getting a resource busy and didn’t know what to do with it … or… MacOS wasnt reporting that error to the app.

Again apologies on the tone of the original post. I was just a bit worried but thats not an excuse.


@cgrunenberg so it appears there are several other threads here in the last several months detailing what might have happened to me last night. I have read issues with Mac OS not dealing with ejecting/unmounting the image properly. You said in one back in May:

This seems to be a bug of macOS 10.14.x which unmounts the volume but doesn’t always eject the disk (although it claimed that it did).

Funny too that you confirmed something I tried which worked, but was wondering about support for. I created a sparse bundle and renamed it to dtSparse which worked a treat. Prefer those just because of the backup issues.

After thousands of replies this year I obviously don’t remember each of them :slight_smile:

@cgrunenberg of that I have no doubt :wink: Just noting that other people had similar problems on 10.14 so easily could have been the same thing.