DT3 loved and adopted > How to do a clean dis-install of DT2?

Juggling with DT3 that I love I have had several issues related to my still having DT2 installed.
Once DT3 is fully installed with all dbases including new inbox (which btw I did not find easy to migrate from DT2 to DT3, I have had several issues now solved but been tricky for me) is working how can I fully get rid of DT2 ?
(Please note I have several tools like AppCleaner, AppZapper etc…but am always worried they would trash components that DT3 still use.)
Thank you for your help

UNINSTALLING DT2 according to manual/documentation

To remove (uninstall) DEVONthink Pro Office completely from your Mac, trash the following files and folders (~ stands for your Home folder):

:black_small_square: DEVONthink Pro Office

:black_small_square: ~/Library/Application Support/DEVONthink Pro 2

:black_small_square: ~/Library/Mail/Bundles/DEVONthink.mailbundle

:black_small_square: ~/Library/Preferences/com.devon-technologies.thinkpro.*

:black_small_square: All DEVONthink Pro Office-specific scripts in ~/Library/Scripts/

:black_small_square: All DEVONthink Pro Office-specific workflows in ~/Library/Workflows/

:black_small_square: All DEVONthink Pro Office-specific scripts in ~/Library/PDF Services/

:black_small_square: Dashboard widgets

:black_small_square: Bookmarklets from your web browser

:black_small_square: The reference to the global inbox folder in your Finder’s sidebar

:black_small_square: Keychain entries containing “devoncloudy”

1 Like

And do realize, you are assuming a risk in switching to version 3 for production or mission-critical work.


I have followed this and may have been overzealous.

I already had installed DT3 but there is now nothing left in ~/Library/Scripts - just empty folders. Have I over done the deleting? The reason I deleted was because the date was October 2021 and I only purchased it yesterday. In retrospect that doesn’t seem like a good theory.

When I opened DT3 everything had gone - no big deal have just been experimenting for now - but I had created three databases and now all gone.

Ok to just carry on or might I have deleted something which will return to bite me?

There were more items than DEVONthink’s in the ~/Library/Scripts folder. However, they are not system-critical and many were probably never used by you.

but I had created three databases and now all gone.

Did you search for them?
If you find them, you can just open them in DEVONthink 3.

Thanks again.

Everything in those folders referred to DT in one way or another.

You’re right the db’s were still there - just had to look a bit harder.

One thing - every time I open a db I get a message that ‘db seems to be already in use’.

This was happening before I embarked on my frenzy of deleting things and it still is.

Any idea what it means?

  • Do you have DEVONthink 2 open along with those databases?
  • DEVONthink may have terminated abnormally and this is the normal message when opening databases that were open when it quit.
  • Your preferences could be bad.

DT2 completely uninstalled along the lines of the post above.

DT3 is crashing a lot and now, today, even worse, I am unable to open 3/5 db’s. The one’s I can open are listed as DEVONthink Database Image and the one’s I can’t are listed as Sparse Disk Image.

It’s early days and I do not have a vast amount of data in DT3 but I would appreciate being able to have a good stable set up so I can crack on.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com - thanks!

Bug report sent

Which email client do you use? Unfortunately there were no logs in the email.

Did you not get the text which begins with MacOS: Version 12.0.1 and ends with Sync Locations: -iCloud (Legacy) (iCloud (Legacy) ) +Dropbox (DropDev.dtCloud )?

Appreciate the rapid response by the way really want to get going with this.

I did but in case of fully supported email clients (meaning scriptable ones) several logs should have been attached too and these logs contain the relevant information.

Email sent using Airmail client. I have tried quitting but ‘option help/bug report’ just opens it again. I was hoping to use the plain gmail client but no joy. What to do? Any chance we can communicate by email rather than forum?

Please send all crash logs (extension .ips or .crash) related to DEVONthink from the folders ~/Library/Logs/DiagnosticReports and /Library/Logs/DiagnosticReports to cgrunenberg - at - devon-technologies.com, afterwards we can of course continue this by email.

There is nothing related to DevonThink in the first location you mention.
I don’t know where the second location is. The only ‘library’ I know is the one on the Alt Go menu of Finder. Pls advise.

You could insert the above paths in the Go > Go to Folder… dialog of the Finder.