DT3 Side-by-Side stopped working in document pane

After several tests and macro configurations following this thread, the “Document Display > Side-by-Side” function seems to have stopped working when a Markdown document is displayed in a document pane (i.e. next to a document list). It does work if the same document is opened in a separate window. I’ve tried restarting DT3 but it didn’t help.

Steps to create:

  • Data > New > Markdown Text
  • Enter any text into the new document
  • Click the icons for Preview, Source and Side-by-Side (or select them in the View menu).
  • Only Preview & Source work. Selecting Side-by-Side has no effect.

I have just confirmed this again with a freshly-created database.

I have made a small video screen capture, available here (for 24h): https://a.uguu.se/eJ0uuDDlQSiJ_DT3.mov

The split separator seems to be on the right side, see different right border after toggling to side-by-side view.

1 Like

Indeed it was. Certainly shouldn’t be happening, though (I had neither moved nor touched it).

Next beta should fix this.


@cgrunenberg Did the beta fix this?

It definitely should.

It’s working here as expected.

I’m having the same problem. The list on the LHS is fine but there is no preview of the document. This is after the update to beta 2, before it was fine.

Welcome @michra

And you’re clicking the buttons in the Navigate bar above the view/edit pane?
Or are you choosing View > Document Display > … ?

The View > Document Display options are all greyed out so I have to use the buttons above the Navigate bar
When I first click on the document title on the LHS, I get a literally 1 sec preview then it disappears. Each time I click around, I get the same 1 sec preview then blank.
If I display it as columns, the middle column gives me a small preview but the RHS is still blank.

When I first click on the document title on the LHS

Can you post a screencap of this, or a screencast of the behavior itself? Thanks!

I’ll try but not sure if I have the relevant software to do that :upside_down_face:

OK I’ve got a short clip. I’ve just tried to upload but it says I’m not authorised to do so.

/Applications/QuickTime Player > New Screen Recording has the ability to record your screen. :slight_smile:

Press the red Record button, marquee the area to capture, then press Start Recording. When you’re done, you can stop the recording by clicking the menubar icon

Close the window to be prompted to save the file, or press the Delete button to trash the recording and start again.

One tip: Practice the behavior beforehand and capture the minimum area necessary to show the behavior. Especially on the displays with high pixel-density we have nowadays, recorded video can get large quickly.

Thanks @BLUEFROG. I sorted the recording out but now can’t upload. Maybe because I’ve just joined the support group?

Ahh, that’s possible. Email it to me at jneumann at devontechnologies dot com

Thanks a lot. On its way. 4.7MB so should be OK.

et al:

In macOS 10.14, pressing Shift-Command-5 also allows you to record screencasts. I had forgotten this until just now since I spend time on previous OSes too. :slight_smile:

OK thanks. Sadly I’m in OS 10.12 still as I have some old software I use regularly and compatibility in anything later seems dodgy :frowning:

If at all possible, we strongly suggest you move to 10.13 minimum instead. High Sierra is basically bug-fixed Sierra, with the same hardware requirements. Sierra was a fiasco, especially concerning PDFs.

PS: Not seeing an email yet. In DEVONthink, hold the Option key and choose Help > Report bug to start a support ticket and attach the video to that. Thanks!