DT3b6 Smart Rule unexpected behavior

“Search in” target is global inbox; destination of “Move to” is a nested group in a database.
The above smart rule puts a copy where intended but leaves an apparent copy of the document in the Inbox with “No File” below the document image in standard view. Seems as if it’s moving the document but not removing the references to it in the inbox, if that makes sense.

Bug, or (more likely), am I doing something wrong?

Are you able to reproduce this and where is the destination database located (e.g. startup volume, external volume or network volume)?

  • Yes, can reproduce including after restarting DT3.
  • Database is on a sparsebundle mounted volume, located on the startup drive.
    edit: have been using that arrangement (sparsebundle volume) for several years with no other known issues.

Thanks for the reply! What kind of file is actually moved and what’s its size? Is the sparsebundle encrypted?

It is an OCRd PDF, 52.1 kb. Yes, the sparsebundle is encrypted.

Do you use any other smart rules that might perform actions too on the same file after importing? So far I wasn’t able to reproduce the issue.

No…I have other smart rules but they should not match this document. And none use “Fuzzy” matching.

Thank you for trying…I will do some more experimenting and let you know if I discover anything.

You could temporarily disable all other smart rules (by performing the actions only on demand). In addition, how is the document imported? Is OCR performed on import in that case too?

I will try your suggestion. Document is scanned using ExactScan, passed to ABBYY Finereader Express for OCR, then renamed based on internal text and moved to the global inbox (All steps but initial scan done by Hazel rules). No OCR performed within DT due to needing the text to rename the file properly.

Changed all rules except the one in question to “on demand.” No change in behavior, but with further exploration, I am more confused.
Setting the rule in question to “on demand” works properly when I paste the item in the finder inbox. The phantom copy is left in the inbox when the rule executes “on import”, again after I paste the document in the finder inbox.
Further, I have so far found one rule, identical except for the selection criteria and destination, that works both ways, and a third rule that displays the same problem as the first. I need to experiment further to see if there are differences that I am missing in the documents and/or rules.
The issue is new, only because I am trying to use smart rules rather than an external script to place the document in the proper DB/Group/Subgroup. So I need to try all the new rules and see which work as expected and which don’t.
Any suggestions would be welcome, thanks for your time and assistance.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com. Maybe the logs will contain some additional hints - Thanks!

Just to chime in, I’m not able to reproduce this issue here either.

@wmc: How is Hazel moving the file into the Global Inbox?

Bug report sent.

Hazel action “Move to folder Inbox” (Inbox is the Finder visible inbox for DT3…
~/Library/Application Support/DEVONthink 3/Inbox.

But it doesn’t matter whether Hazel moves the file or I place a copy in the same inbox dragging into the sidebar or pasting into the inbox.

The issue seems to be caused by the enabled barcode scanner, we’ll investigate this.

Thanks for finding the issue. So far I have not been able to repeat the “phantom document” staying in the inbox with the barcode scan preference item (import tab) unchecked.