DTP icon in Scripteditor Library not responding


I can’t access DTP’s AppleScript dictionary from the Scripteditor’s Library (added it there, the icon is shown) when DTP is not already running.The icon there doesn’t respond to doubleclicks or selection it and a click on the toolbar icon. Other tested icons respond within a second or two. Scripteditor’s menu “Open Library…” works, although sometimes with a large delay when DTP is not running.

Could there be an issue between an initialization and a timeout ?


Most applications, e.g. TextEdit, have to be running to access the script suite via the library.

If your default database is very large and/or your computer quite slow, then launching DTP might need some time.

Hello, Christian,

thanks for pointing that out. I tried again: DTP open (flashscreen gone, menus responding), no DB open, then launched Scripteditor, removed old DTP entry from the library and renewed it, then tried double-click or the toolbar icon.
Two minutes later: no response, also not to a new double-click either. Other app’s dictionary do come up immediately, so I guess there must be something or other with DTP. If I can be of help in a bughunt, let me know.

Greetings, Br@

You might try if reinstalling DTP (and ensuring that there’s only copy of DTP on your system) will make a difference.

I’ll try that. Thank you.


Even after reinstalling there was no reaction, but there is a solution.

After opening (via scripteditors menu) my DTO was showing up TWICE in the applications list, with identical paths, although there was only one instance on the system.

Not selecting one of them but manually loading the DTP dictionary through “Browse…” and the following dialog did make it work. Hope that is of help to anyone with the same trouble.


This may be an example of a LaunchServices database glitch. You can fix this by forcing a rebuild of it using a cache cleaning utility.

I’ll do so. Thanks!