DTPO 2.10 (and DTTG 2.6.1) too buggy. Can downgrade?

Just after done steps described in previous message, I got back in my global Inbox some items I’ve previously moved from global inbox to other database folders, and when try to move them (drop) over the DB inbox, I get the “UUID already in database” error.

This is a very nasty (and repeated) issue that can risk database integrity… Currently I’m not sure if I’m in risk to lose all my stored data.

This never happened in versions previous to 2.10. When are you going to release a fix for this?

Yepp , that is also my problem since 2.10 - and it is reapeating.

I deleted these entries in the Global inbox after I have checked that they are really in place in their target databases. However, after a short time they reappear again in the inbox!

I’m seriously thinking in going back to Evernote.

The real problem is not having this issue, the real problem is the risk database gets corrupt and you lose all your accumulated stuff.

F*ck! Even deleted (and trash emptied) entries have been recovered into inbox!!

Return to Evernote - this sounds for me more as an overreaction.

However, I would be satisfy to understand the reason for the problem (technical description). I do not observed any data loss, but this behavior is not really comfortable right now.
Therefore, a quick fix is necessary.

Yes, it is, because I had a lot of other complains about Evernote… We are in the mediocrity age. :unamused: :unamused: :unamused:

I would like to have some kind of warranty no data will be lost.

And yes, I can beta test for this issue if they want.

This might be an issue of the new background sync of DEVONthink To Go 2.6.x, especially in case of huge databases and/or older iPhones/iPads. Switching to synchronizing on demand instead of automatic should fix this.

Thank you for your response.

I’m using tree IOS devices:

  • iPhone 7+
  • iPhone SE
  • iPad Pro 10.5

On all devices is enough storage available.
My biggest DB has about 3 GB with about 2500 pdf files, from my understanding this is not a huge size.

How do you define “older” iPhones/iPads?

However, I’m following your advice and disable on the “oldest” iPhone SE the automatical sync.
I will also install 2.6.2 on all devices

Just installing 2.6.2 in my iPhone. This evening I will update all my other iThings. However, the release notes does not talk about this issue.

I don’t have “old iThings”. Well, I have an iPad mini 4 that can be called “old”… Mmmmm… I think it should fail after I use it… I use that iPad to read before going to sleep, and DT works fine all day and when I start next morning, global inbox had deleted and phantom items…

It’s a random issue but both larger databases and older iPhones/iPads make it more likely as the background sync doesn’t get enough time.

Version 2.6.2 fixes only other issues.

Now I have a new issue. Yesterday I converted some formatted notes to PDF via the Convert to PDF script and deleted the formatted notes. In my Mac.

After syncing with DTTG, now iThing devices have the “cannot upload x items”, and I have duplicated the formatted note and the PDF in DTTG but not in my Mac.

Re: “This might be an issue of the new background sync of DEVONthink To Go 2.6.x, especially in case of huge databases and/or older iPhones/iPads. Switching to synchronizing on demand instead of automatic should fix this.”

Can you give some indication of what size [words or GBs] a huge database is? Also what is the advantage of switching to on demand sync from automatic sync in this situation?


There is no “advantage” being proposed here. It is suggested in relation to the issue reported earlier in the thread.

i tried several things with switching to on demand syncing, but the problem still re-occurs.
New for me is that even deleted (and trash emptied) entries have been recovered into inbox (same observation as others).

Before 2.10 / 2.6 I do not ever have any problem with syncing ! The hardware environment is still the same; I only switch one DB from Cloudme to iCloud; all other DB’s including the global inbox did not change.

What is going wrong with the Global Inbox / Trash in 2.10 / 2.6?

Did you disable automatic synchronizing on all iPhones/iPads?

No, only on the iPhone SE and on the iPad Pro.
On iPhone 7+ it was furthermore activated.

Should I also deactivate the automatic sync here? I hope only for testing, because the automatic is very comfortable.

It should be deactivated on all devices. Another possibility is to open a support ticket and to request a beta of the next maintenance release which should fix this.

Ok, thanks.

I will deactivate the (automatic) sync also on my iphone.
I can live with this workaround.

However, next maintenance release - sounds good :slight_smile:

Disabling automatically sync in all iThings, and wait manual syncs with the app open seems resolves the issue. At least I had no more problems after that.

Let’s wait until the bug fix. :slight_smile:

Any chance this could be resolved soon?

After some hours I enabled automatic sync in ONE (only one DTTG) app, it starts giving the UUID and the upload problems.

And it happens in any device, does not matter who old is it. iPhone 8, iPad Pro 10 and 13…