DTPO stuck while downloading a web clipping

I experienced a problem yesterday while sending a clipping (formatted note, non clutter free, via the DTP extension for Safari 11) to DTPO. What happened was that DTPO basically became stuck, as you can see from this screenshot:


That “Downloading…” message never changed. I tried pressing “Synchronize”, quitting the app, clipping the web page again, to no avail. At one point, some DEVONThink helper app started using a lot of CPU time. Quitting DTPO fixed that. Even after restart, nothing had changed. Finally, I opened DTPO on my iPad, and one clipping was added to my database’s Inbox — but it was a clipping from long ago, not the one I had just made.

This still happens for http://gallica.bnf.fr/blog//17102017/quand-leducation-sentimentale-se-faisait-trepigner-par-ses-contemporains

I delete the remote database stores, deleted and reestablished the database connections, and I’m still seeing the problem. The most recent time I tried to save a clipping (this time as rtf, not as a formatted note), DTPO crashed!

Process: DEVONthink Pro [928]
Path: /Applications/DEVONthink Pro.app/Contents/MacOS/DEVONthink Pro
Identifier: com.devon-technologies.thinkpro2
Version: 2.9.15 (2.9.15)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: DEVONthink Pro [928]
User ID: 501

Date/Time: 2017-10-17 14:55:02.173 -0500
OS Version: Mac OS X 10.12.6 (16G29)
Report Version: 12
Anonymous UUID: 67776EE6-3F6D-E2C3-79C6-01AADF23778A

Time Awake Since Boot: 2000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x000002c720209094

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

Second try: DTPO has displayed the “Downloading…” window, which is stuck. An according to Activity Monitor, the process com.devon-technologies.get is not responding and using 200% CPU.

Any ideas as to how to fix this?

The issue is with that page. Even a Bookmark to gallica.bnf.fr/blog/17102017/qua … temporains is crashing DEVONthink.

PS: The URL you provided has “///” instead of the URL I presented above.

Okay, but Evernote can clip the page – why can’t DTP?

There is no “web clipping standard technology”. We can’t account for what Evernote can do as they employ whatever technology they use.
Your support Ticket has been forwarded to Development.

This is an issue of Sierra’s WebKit framework crashing DEVONthink. On High Sierra it’s possible to successfully clip this page as a formatted note (both clutter-free or not).