DTPO (v2) suddenly stops accepting my registration key

I have been using my DTPO (v2) license for many years without any problems.

But today suddenly my registration key doens’t seem to be accepted anymore. I have already made a DT3 purchase back in May (assuming the final release would be here in Summer).

When I log in my account now see a stripe through my DTPO license (didn’t notice that before). But I am wondering why I wouldn’t be able to use my v2 license while we are awaiting the final v3 release?

Can anybody shed any light here? I am currently locked out of my databases, which is pretty annoying.

Solved here: DTPO 2.11.3 won't allow search or edit? expired 31 August?

TL;DR: you can use your DT3 license data for DT2

Nope, if I enter my DT3 license it asks me to install DT3.x

Apparantly DT3 will happily accept my license code, but then I end up unhappy with a beta version in production.

Interesting… if you can wait, then maybe best to wait for DT to respond. Otherwise I think I would install DT3, register, and then use the same data to register DT2 again. Can’t promise that would work, but if you don’t currently have DT3 installed, that would be the obvious difference between your situation an mine.

Well, you were fast, but usually @BLUEFROG is faster than any other user.

(perhaps he’s interested in a Discourse-Neuralink trial :slight_smile: )

1 Like

I was, but being fast is not much use if I’m being useless at the same time… sorry my solution didn’t work for you :frowning: However, things will work out for you - DT is good that way :slight_smile:

I’ve had an alpha Neuralink implanted for a year now.
I can actually detect all your posts before they’re even written :thinking:
On the other hand, I uncomfortably attract small metal objects, including pointy ones! when I get too close :stuck_out_tongue:

@anon6914418: The DEVONthink 3 license should work for DEVONthink 2. However, you can’t exceed the number of purchased seats for 3. Is that the case?

1 Like

I’ve had an alpha Neuralink implanted for a year now.

Yes! I knew it! :slightly_smiling_face:

The DEVONthink 3 license should work for DEVONthink 2. However, you can’t exceed the number of purchased seats for 3. Is that the case?

I’ve tried the seats on on early beta version of DT3 on two separate devices, but those devices have been reformatted afterwards. Should I have “de-authorized” them or something?

It doesn’t seem like it, as I currently have two seats awaiting a driver according to the website:
Seats 2 Used - [purchase date]

When I enter the key, it is recognized as a valid DT3 license, but it will not proceed with the DTPO boot up. Instead it offers me to download DT3.x :frowning:

The question that remains from my point of view, is why did the old license stop working? Isn’t that license valid anymore?

I have just checked the DTPO (v2) license with a currently air gapped device, that was authorized with the v2 license earlier this year. I can confirm I can run DTPO on that device, but obviously cannot sync with it.

How do I proceed from here on?

The DT3 license does not allow me to boot up DTPO (v2), but asks me to download DT3. I have no intention to install a beta version in a production environment.

Why does DTPO suddenly stop running, and accepting the v2 license key on my primary device?

Which version of DEVONthink Pro Office do you use? The latest one (2.11.3) should accept licenses of version 3.

Well, this is getting weirder by the minute. According to the Update menu in DTPO 2.11.2 is the most recent version.

Why wouldn’t DTPO find 2.11.3 as the most recent version?

Also this does not answer the question as to why the old license key is no longer accepted.

E.g. if the traffic to our website is blocked (e.g. by Little Snitch) or some server caches the information. But it’s also available on our website (https://www.devontechnologies.com/support/download/legacy)

The server clearly isn’t busy, as it tells me this version is up to date.

I do not use a proxy.

Could you answer this question? I’ve asked it several times but no one seems to be addressing it.

Specifically why did 2.11.2 work flawlessly up until last week, and now starts asking me for a license key. It doesn’t make any sense.

Did you already buy an upgrade to version 3? Then your old license isn’t valid anymore and you have to use the new one in both version 2 & 3.

Is it safe to conclude that DevonThink keeps checking the validity of my license after autherization, by contacting your license server (“phoning home”)?

Does DevonThink use some timer to keep working following a certain time after authorization?

I am asking these questions as I am faced with non-working software, while holding a valid license key. Which I cannot use, up until I do a minor update. Whih I wasn’t aware of, as the updater tells me the software is up to date.


Usually not but in this case (upgrade from version 2 to version 3) there was a delay until the old licenses became invalid.

Now its clear. Thanks for the insight!

I really couldn’t wrap my head around the situation that my DT2 was running fine, until it suddenly quit 2 or 3 days ago. This was even more confusing as the Help text in DT2 states:

You only have to re-enter your license code after a complete reinstall of your
system without a backup of your home folder or when the license code file has
been deleted, e.g. by a preferences cleaner app. The license code is stored in a
preference file in ‘~/Library/Preferences’ (where ~ is your home folder). As long as
this file is intact, you’ll NEVER have to enter your license code again.

Unless you happen to buy a DT3 license early and await the final release, skipping all the betas. The fact that 2,11.2 did not allow me to enter the DT3 key and reported that 2.11.2 was the most recent version, contributed even more to the confusion.

That said, I upgraded to 2.11.3 this afternoon, used the DT3 key and following testing can confirm I have a working version of DTPO again. Hooray! :slight_smile: