DTTG 2.7.9 search crashes

Using DTTG 2.7.9 on a 2020 iPad , when I try to search using the search box on the main page of the app, the app closes as soon as any data is entered in the search box. Have tried restarting the iPad, no change.

Any thoughts please?



I note you are using an older version of DEVONthink ToGo. Might want to upgrade to current version 3.1. (and upgrade IOS if not current version).

That being said, when I see that sort of crash on IOS apps (not frequent, but happens), I simply delete the app and resinstall from the Apple App store. Something corrupted on the machine. What? Who knows? Could be hardware. Could be software. Could be cosmic rays. :wink:

Suggest trying that as a first step.

This has been described before. @BLUEFROG recently posted that DTTG 2 is no longer under development, and that a known crash (I don’t know which one he was alluding to, and can’t find the post off-hand) would no longer be rectified. My understanding is that DTTG 2 worked on the day that 3 was introduced, and that any problems occurring now (e.g. due to incompatibility with newer iOS versions) will no longer be salvaged.

Ah, here it is, and Jim was alluding specifically to the search bug. It’s time to upgrade (that is assuming the bug persists on iOS 14.6; there was a search bug in Preview which was rectified with the update to macOS 11.4, so it’s not completely out of the question that the bug was in iOS rather than DTTG…)


That sorted it! Thanks.

You’re welcome! Which worked? :slight_smile: Updating to iOS 14.6 or to DTTG 3?

Upgrade to DTTG 3 :slight_smile: